Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an odd problem with a wireless network.

I have 3 Dell laptops in the house, which we'll call BlackDell, BlueDell and Dellbert. There's also a Tosh. We have a ClearWire hotspot modem. All 4 machine have been accessing the hotspot for about a year. Now, there's a problem with Dellbert. When Dellbert connects to the ClearWire, it completely freezes within 4 minutes. It doesn't matter if if the machine is active or idle.

BlackDell, BlueDell and Tosh connect fine (I'm using BlueDell to post this).

Dellbert can connect to any other wireless and run for days.

Dellbert generally runs Win7 64. However, I have a Debian Squeeze install on an external drive. If I boot into Debian, Dellbert happily connects to the network and will run for hours.

Network card is Dell 1501 (Broadcom)

All in all, I'm pretty sure that something stored or cached somewhere is corrupt, but I have no idea. I hadn't used the machine in the house for a few months, kept it in the office, so I don't know when it may have stopped. Loads of Windows updates in that time, so it could have been any of them.

I've deleted the network.

I've reset winsock.

I've run out of ideas.

share|improve this question
    
Maybe not run out of ideas. I changed the DHCP from 192.168.1.0 to 192.168.185.0 with the hope that forcing a new IP might work. –  Aaron Jul 7 '11 at 2:32
    
Other things I've tried. Modifying router to use channel 1. Removed tcp/ip v6 since I'm not using it anywhere. Turned off QoS from the adapter settings. –  Aaron Jul 7 '11 at 2:49
    
Last thing I tried before giving up for the night was turned off Link Layer Topology Discovery Responder. –  Aaron Jul 7 '11 at 3:00
    
Did you roll back the wireless adapter to a previous driver? Maybe Windows updated your driver for you?" You'd be using a different driver when booted into Debian, so obviously your hardware is fine. –  goblinbox Jul 7 '11 at 3:41
    
Thanks. I did roll back to a few weeks before, but nothing. I've also reinstalled the Dell drivers. Driver dates (according to Windows Device Manager) are in the 2009-2010 range. That the Dell portion and the Broadcomm portion. I'll rummage through Dell's driver list again and see if there's anything. They use lots of helper software. –  Aaron Jul 7 '11 at 11:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.