Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seem to have encountered a bug in Emacs, but I have no idea how and where, nor how to fix it. Emacs has been working perfectly fine on the server previously.

When I open files Emacs correctly prints the content and places the cursor. However, the cursor is one line below the text it is modifying. Typing places text at the cursor, but it is actually modifying the line above, as can be seen if reloading the file.


Hello World!

Now, press delete:

Helo World!

And now press l:

Helo World!

Reload the file:

Hello World!

Any idea what can cause this behavior or how to fix it? I am connecting to the server over SSH using Putty. The server is a standard Ubuntu 11.04

share|improve this question
I am not sure i understand the question. However did you try opening the emacs as emacs -Q? it tells you whether the problem is related to your .emacs (config file). could you post emacs version which you are using.? so that some one else can check the behavior – kindahero Jul 7 '11 at 16:07
@kindahero No reported errors. Emacs 23.2.1. I suspect that the error is not in Emacs, but is something related to putty and the server, as I see the same behavior in editors such as Nano. But I can't imagine what might cause it. – pehrs Jul 8 '11 at 20:05
up vote 1 down vote accepted

It sounds like a terminal setting issue is messing up screen display. Try making sure your putty is emulating VT100. Then, after you connect the server, in the Bash shell, type

export TERM=vt100

then run your emacs. Windows and Putty are both screwey about this; you might have to fiddle a little.

share|improve this answer
That was pretty much the solution I used in the end. – pehrs Apr 3 '12 at 11:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.