Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, the other day, after at least two years of being annoyed by the question that Windows gives when I try to run a program that I downloaded, which asks me if I'm sure I want to run it; I searched IE options for anything that would disable that question.

After a long time searching, I finally came upon one security setting which enable me to suppress the question. I disable it and browsed the web happily using Chrome (my main browser) for about two days, when I needed to open IE in order to access a website that was designed for Microsoft browsers. That's when I came upon another, much more bothering, message:

Security at Risk

The worst part is that the message doesn't disappear after browsing to a site or anything. Anyone knows what I could do? Besides, of course, restoring the setting?

share|improve this question
    
Google Chrome Frame is awesome as it installs like a browser plugin, in to IE.. Using that, you can then use IE, or so you think, except everything's actually driven by Chrome - which you know, is good. –  Doc Jul 7 '11 at 18:14

3 Answers 3

Open Group Policy (type gpedit.msc in the Search programs and files field). Go to

Computer Configuration | Administrative Templates | Windows Components | Internet Explorer

Look for Turn off the Security Settings Check feature and set it to Enabled.

enter image description here

share|improve this answer
4  
This answer makes me happy. I can't wait to do this at home. –  mjb Jul 7 '11 at 18:30
    
It looks like the right way, but for some reason it didn't worked here. Sure it works for IE9? One more thing: this has a !@#* side effect: Windows Live Mail stops synchronizing e-mail for some reason. I'll investigate it further this afternoon. –  Bruno Brant Jul 12 '11 at 13:51

This site suggests you can set HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Security\DisableSecuritySettingsCheck (DWORD) to 0x1 to kill the error message.

The main problem with downloading and running executables with IE is that the download dialog can be tricked into making you believe the file is not an application, but a document (for example by using Unicode characters in the name that change the writing direction so that cod.exe is shown as exe.doc) - especially since you can change the icon of exe files easily. So, the extra prompt for applications does make sense (you can also configure the same prompt for network or removable drives). If you are sure, you can of course disable it. Or use another browser that ignores unicode direction change characters in names that consist only of ASCII letters (where it is useless, unless in some languages like Arabic or Hebrew).

share|improve this answer
    
For me, HKEY_LOCAL_MACHINE\SOFTWARE\POLICIES\MICROSOFT\Internet Explorer\Security\DisableSecuritySettingsCheck set to 0x1 worked, but I had to actually add the Internet Explorer\Security\DisableSecuritySettingsCheck portion (those keys were not already present). –  Chaser324 Jan 21 at 10:00

The method described by Nicu Zecheru does work with IE9 in order to get rid of the "Security Risk" banner, however you must reboot for the new policy to take effect. Once rebooted open your IE9 Browser and open the a web page. The only warning that will come up is "Press here if you do not want to see the warning again", close the browser again and reopen and no warning banners will appear after.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.