Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Ubuntu 11.04 (guest) on Windows 7 (host) with the guest additions installed. I have an auto-mount folder that maps to my D: drive on the host which I can access using sudo ls /media/sf_D_DRIVE - however, even when my user (ross) is a member of the vboxsf group I get a permission denied error when attempting to explore it. I have restarted since adding my user to the vboxsf group.

This should work because I am a member of the group (which has rwx rights), so why doesn't it?

ross@panther:~$ ls -l /media
total 8
drwxrwx--- 1 root vboxsf 8192 2011-07-03 22:24 sf_D_DRIVE

ross@panther:~$ ls -l /media/sf_D_DRIVE/
ls: cannot open directory /media/sf_D_DRIVE/: Permission denied

ross@panther:~$ id ross
uid=1000(ross) gid=1000(ross) groups=1000(ross),4(adm),20(dialout),24(cdrom),46(plugdev),112(lpadmin),120(admin),122(sambashare),1001(vboxsf)

ross@panther:~$ sudo ls -l /media/sf_D_DRIVE/
total 84
drwxrwx--- 1 root vboxsf  4096 2011-07-06 14:46 Development
# ...snip...
drwxrwx--- 1 root vboxsf     0 2011-05-25 19:13 Videos
share|improve this question
up vote 75 down vote accepted

I had added my user to the vboxsf group:

sudo usermod -aG vboxsf $(whoami)

I did do a restart, but after logging out and in again, I got access! Restarting after this and it still works. Go figure.

share|improve this answer
1  
why is the need for a restart? – Praveen Sripati Oct 19 '11 at 2:15
    
Not sure, it just seemed to correct itself. – Ross Oct 19 '11 at 7:50
12  
See here why a restart is required. A logout/login would do. – Praveen Sripati Oct 19 '11 at 14:01
1  
This answer command has to be run on the GUEST machine! – KrisWebDev Apr 2 at 22:08
    
Just tried this with Lubuntu 16.04, my user was created in the vboxsf group, however it was not checked... so was added but disabled. Checking the username and logging out/in or rebooting got it working. – rdtsc Jun 2 at 14:01

I followed this procedure: Check that your user account is in the vboxsf group. Click on the bird icon, select Users and Groups → Manage Groups → vboxsf → Properties. Your user account should have a checkmark next to it. Check it if it is unchecked. When prompted for a password, enter secret.

Then a restart on the virtual machine (Power of the Machine) and this allowed for the shared folder to work.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .