Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Does anyone know if there is a "sticky note" application for Rhel5? In Ubuntu, there is Xpad and Tomboy, but I couldn't see an rpm version for this. I tried to download the tarball for Tomboy but it was giving this error:

configure: error: gnome-doc-utils >= 0.17.3 not found
share|improve this question
You can get the tarball for the package missing here – Simon Sheehan Jul 8 '11 at 23:47
I installed the 0.17.5 version and removed the older gnome-doc-utils that was installed via rpm. And yet it still cannot find the gnome-doc-utils. I think it is a path issue but I don't know how to tell configure to look for the path and I don't even know where gnome-doc-utils was installed. – Carmen Jul 11 '11 at 19:39

If you're using KDE, KNotes is what you need.

KNotes is a program that lets you write the computer equivalent of sticky notes. The notes are saved automatically when you exit the program, and they display when you open the program.

enter image description here

share|improve this answer
unfortunately, I am using gnome. But is there a way to install this application in gnome? – Carmen Jul 8 '11 at 19:26
Yes, there is. However installing a KDE app on gnome will require many dependencies, thus I don't recommend it. The app you're looking for is Gnote than, mentioned in @Patches answer below. – lisa17 Jul 8 '11 at 19:57

Tomboy requires Mono, which AFAIK RHEL does not ship. You might want to take a look at Gnote, which provides similar functionality but does not require Mono.

Gnote is available in the RepoForge (formerly RPMForge) third-party repository for Red Hat Enterprise Linux. First, enable that repository and then you can install Gnote with the following command:

yum install gnote

Unfortuntately, they don't build it for RHEL5, but you can rebuild an RPM using the source RPM (SRPM). To do that, first you need to download the SRPM. Then, tell YUM to install rpmbuild if you don't already have it, by running this as root:

yum install rpmbuild

Next, install all dependencies needed to build it, again as root:

yum-builddep gnote-0.7.2-0.1.rf.src.rpm

Now you can rebuild the package using this command, which you should not run as root:

rpmbuild --rebuild gnote-0.7.2-0.1.rf.src.rpm

That will build and drop an RPM in ~/rpmbuild/RPMS/<arch>, where <arch> is i386 or x86_64 depending on whether you have a 32-bit or 64-bit operating system installed. All you have to do then is install it, as root this time:

rpm -ivh gnote-0.7.2-0.1.el5.rf.i386.rpm
share|improve this answer
interesting. I 'enabled' the rpmforge repository and yet it still could not find the gnote rpm. – Carmen Jul 8 '11 at 19:00
Ugh. Looks like they only built it for RHEL6. I'll post instructions on how to rebuild it from the SRPM. – Patches Jul 8 '11 at 23:10
when I run this: yum-builddep gnote-0.7.2-0.1.rf.src.rpm, it complained that Error: No Package found for dbus-c++-devel. And it looks like this package is also only available for rhel6. Hmm. – Carmen Jul 11 '11 at 18:46
They don't call it dependency hell for nothing. ;-) Rebuild dbus-c++ from the RHEL6 SRPM following the above instructions. That SRPM will build both the dbus-c++-devel package needed to build gnote and the dbus-c++ library package needed to actually run it. Go ahead and install both in the last step. Then, try building gnote again. (P.S. I double-checked the spec files and everything else seems fairly vanilla, so you shouldn't have any more surprises. :-) – Patches Jul 11 '11 at 23:14
@Carmen you don't suggest an edit on an answer to add clarifying information about what happened. You either edit your question, or leave the info in comments. – nhinkle Jul 12 '11 at 0:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.