Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Device Manager, my Video Controller's driver is marked as Not Installed. I click on "Update Driver" and it contacts Windows Update and all that jazz and downloads the Intel Mobile Graphics Driver and starts to install it. Then it fails saying Access Denied. I look in Control Panel -> User, and I have Administrator status. How do I fix this?

It is on Windows XP SP2. EDIT: Looked into setupapi.log and found registry problems. I paste the relevant parts:

#-011 Installing section [iCRG0.Interfaces] from "c:\windows\system32\drvstore\kit12928_7a98a40ec8a4e16d6b66c417f29520b781aadab4\kit12928.inf".
#I054 Interfaces installed.
#-166 Device install function: DIF_INSTALLDEVICE.
#I123 Doing full install of "PCI\VEN_8086&DEV_2A02&SUBSYS_01F91028&REV_0C\3&61AAA01&0&10".
**#-007 Deleting registry key HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\igfxcui
#E033 Error 5: Access is denied.**
#E065 Parsing DelReg section [CUI.DelReg] in "c:\windows\system32\drvstore\kit12928_7a98a40ec8a4e16d6b66c417f29520b781aadab4\kit12928.inf" failed. Error 5: Access is denied.
#E064 Parsing install section [iCRG0] in "c:\windows\system32\drvstore\kit12928_7a98a40ec8a4e16d6b66c417f29520b781aadab4\kit12928.inf" failed. Error 5: Access is denied.
#E122 Device install failed. Error 5: Access is denied.
#E154 Class installer failed. Error 5: Access is denied.
#I060 Set selected driver.
#I125 Installing NULL driver for "PCI\VEN_8086&DEV_2A02&SUBSYS_01F91028&REV_0C\3&61AAA01&0&10".
#I121 Device install of "PCI\VEN_8086&DEV_2A02&SUBSYS_01F91028&REV_0C\3&61AAA01&0&10" finished successfully.

Sigh screw you windows...


share|improve this question
What OS do you have? – KCotreau Jul 8 '11 at 13:56
@KCotreau he mentioned "It is on XP" I think. – avirk Jul 8 '11 at 16:08
@avirk Notice he edited it...THAT was the edit. – KCotreau Jul 8 '11 at 16:11
Oh I didn't see that my fault sir. – avirk Jul 8 '11 at 16:12
up vote 0 down vote accepted


I had the same problem after trying to use a utility called "Driver Genius" to update the drivers on my Acer Aspire 3690 laptop with the Mobile Intel 945 GM Chipset. Driver Genius screwed up my drivers. Not so genius really.

First I went to my laptop manufacturer, the Acer website, and downloaded the Mobile Intel 945 GM Chipset Family drivers for WinXP. It had an executable setup file to install the Intel drivers. It would not work. Well, it said it worked, but it didn't work. The dialogue reported "Installed successfully" and I clicked finished but nothing. It did not fix the display adapter problem. Well then I tried to update the driver manually from the extracted zip file from the Acer download. I had the exact same problem as you did when trying to update the display adapter manually. I got "access denied". I didn't know what to do with that until I found this thread and saw your setupapi.log information. I knew nothing about the setupapi.log utility. So I went to start/run/setupapi.log on my laptop and got back basically the same log report as yours. The file I was being denied access to was "igfxcui" in the same registry location as yours, HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\igfxcui.

Here's the very simple solution:

Locate the igfxcui folder in the registry by going to start/run/ then type in regedit. Navagate to HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\igfxcui in the registry and RIGHT CLICK on the igfxcui folder. It will show a list of options. Go to "Permissions". Click on the "Add" button. Go to "Enter object names to be selected" and type in your Windows user name then click on the "Check names" button. Your user name should pop up along with your computer name. My came up "Todd-laptop/Todd". Click on "Ok". Then highlight your user name and in the "Permission for (your user name)" field on the "Full Control" line, put a check in the "Allow" box then click on "OK". Now you will have permissions back to change the registry keys in the igfxcui folder when you manually install the adapter drivers.

After I changed permissions for the igfxcui folder, the drivers installed manually with no problem. I got my Mobile Intel display adapter back. Then go to your desktop, right click, then go to properties/settings/advanced and click on "Intel Graphics Media Accelerator Driver for Mobile" and put a check in the "Show tray Icon" box and you will have your display properties thing back in your tray icons. Also, right click on your desktop and go to properies/settings/advanced/monitor and uncheck the box by "hide modes that this monitor cannot display" and click ok to open up all the resolution settings. I had to do this to get the resolution I wanted on my display. I have never messed up any of my monitors doing this contrary to the warning.


share|improve this answer
what a mess... but thanks! – rabbid Aug 12 '11 at 16:37

I would try downloading the official drivers from the manufacturer's website, instead of relying on windows to find them.

Go here, select your OS and other information then see if they have an available graphics driver for you to download. Once, you've got it, it's mostly just a question of installing like any other program.

share|improve this answer
+1 Always best to use the manufacturer driver. Windows update has provided bad drivers more than once. nVida specifically warns users to go to Dell for drivers for their card – Dave M Jul 8 '11 at 14:12
I have done that as well. Downloaded from Dell's website. Same problem. – rabbid Jul 8 '11 at 14:32
Try accessing the system account, follow the instructions here: – n0pe Jul 8 '11 at 14:36
Tried installing using System account. Still no luck. I looked into setupapi.log and found registry problems. Please refer to my edits above. Thanks – rabbid Jul 9 '11 at 3:52

Just because you are an Administrator or System does not mean you have permissions to everything. You can configure the ACLs on folders and registry keys to disallow access to Administrator and System.


#E065 Parsing DelReg section [CUI.DelReg] in "c:\windows\system32\drvstore\kit12928_7a98a40ec8a4e16d6b66c417f29520b781aadab4\kit12928.inf" failed. Error 5: Access is denied.

I would open kit12928.inf, find the DelReg section and see what registry keys it references. Then check that you have access to those registry keys using regedit.

That said, if someone has messed up your registry ACLs then you would be better rebuilding the system from scratch.

share|improve this answer
What's an ACL? Sigh I can't even find that folder within DRVSTORE/ Why is Windows so complicated to fix? Why isn't there just a root like in UNIX.. – rabbid Jul 9 '11 at 9:56
From the log it looks like the troublesome registry is HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\igfxcui. I looked into that reg and its permission for Administrator is Full Control and Read. I tried to delete it and I couldn't. What do do? – rabbid Jul 9 '11 at 10:07
Figure out why you can't delete it :) – Jul 9 '11 at 10:21
well if I knew I wouldn't be on superuser would I? I guess I'll open another question... Thanks anyway. – rabbid Jul 9 '11 at 17:35
You can use Process Monitor to watch what regedit is trying to delete and see the error message that is returned. I assume you're running regedit elevated (or as administrator with UAC off), as well. – Jul 9 '11 at 22:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .