Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On the left is firefox 4, on the right is chrome 12.

On the left is firefox 4, on the right is chrome 12. Is there a way to make chrome render prettier fonts?

The above image was taken on windows xp. Below is another example from windows 7.

enter image description here

share|improve this question
    
Linux or Windows? –  Nicu Zecheru Jul 8 '11 at 17:05
    
Windows. The screenshot above was taken on windows xp. It looks a bit better on my windows 7 machine, but some sites definitely still suffer. Here's another example: i.imgur.com/zbuUr.png –  hughes Jul 8 '11 at 21:52
1  
Are these default OS fonts or embedded fonts? (Such as via TypeKit.com)? –  red Jul 12 '11 at 6:17
1  
You know, that's a good question. It's most noticeable on embedded fonts. Web-safe default fonts look fine. Everything on TypeKit.com looks jagged and horrible. –  hughes Jul 12 '11 at 13:22
    
TypeKit rendering looks really really different on different browser \ operating system combinations, sadly. :( –  red Jul 12 '11 at 13:32
show 1 more comment

14 Answers 14

up vote 25 down vote accepted
+100

Check ClearType settings - the Chrome screenshot looks like it's being forced to render non-anti-aliased. That will kill just about any web font, since they don't have monochrome hints (for size reasons among other things). I used to see this reported as "IE renders text better", because it ignores your OS-level ClearType settings and turns it on by default.

share|improve this answer
    
Wow, this was the whole problem. I guess Firefox ignores cleartype settings too. Thanks! Enjoy your bounty! –  hughes Jul 13 '11 at 12:52
6  
"it ignores your OS-level ClearType settings and" and what? –  Oliver Salzburg May 25 '12 at 12:31
    
Also turning of GPU acceleration worked for me. See lonesysadmin.net/2011/09/12/… –  Jimmy Bogard Aug 12 '12 at 18:43
5  
Where would one go to check ClearType settings? –  Harveybars Nov 4 '12 at 4:47
1  
This answer explains how to do it on XP -- there's no "ClearType" in Start or in the Control Panel. superuser.com/a/441694/46972 –  ashes999 Aug 15 '13 at 2:06
show 2 more comments

All those answers are wrong! This is a big bug in Google Chrome, please see the official bug report/thread including lots of screenshots here: Official bug report on Chrome Code

Currently the best workaround is to simply give your element/headline this simple rule:

-webkit-text-stroke: 1px

Addition from Dr John: I found a suggestion that html { -webkit-text-stroke: 0.25px} would work as well - found it here https://groups.google.com/forum/?fromgroups#!topic/mathjax-users/dV_TmJ1QMO4

share|improve this answer
add comment

Place the SVG file higher in the font-face css rule, either 1st or second for example:

@font-face {
font-family: 'gothbook';
src: url('fonts/gothamrnd-book-webfont.eot');
src: url('fonts/gothamrnd-book-webfont.eot?#iefix') format('embedded-opentype'),
     url('fonts/gothamrnd-book-webfont.svg#GothamRoundedBookRegular') format('svg'),
     url('fonts/gothamrnd-book-webfont.woff') format('woff'),
     url('fonts/gothamrnd-book-webfont.ttf') format('truetype');
font-weight: normal;
font-style: normal;
}

Instead of:

@font-face {
font-family: 'gothbook';
src: url('fonts/gothamrnd-book-webfont.eot');
src: url('fonts/gothamrnd-book-webfont.eot?#iefix') format('embedded-opentype'),
     url('fonts/gothamrnd-book-webfont.woff') format('woff'),
     url('fonts/gothamrnd-book-webfont.ttf') format('truetype'),
     url('fonts/gothamrnd-book-webfont.svg#GothamRoundedBookRegular') format('svg');
font-weight: normal;
font-style: normal;
}

Examples of this fix can be seen here:

FontSpring Examples
Adtrak Examples

share|improve this answer
    
Thanks so much!! On a past project I noticed that OTF looked really good as well, I tried it on another project and it looked terrible! SVG looks really good =) –  Ceane Lamerez Apr 19 '13 at 20:54
add comment

Chrome is reading your ClearType setting which on Windows XP is switched off by default.

  1. To fix the issue, first close the Chrome browser.

  2. Now right-click anywhere on the desktop and select 'Properties' from the drop-down menu.

  3. Click on the 'Appearance' tab found along the top on the new window.

  4. And click on the 'Effects' button.

  5. The second option down should read, "Use the following method to smooth edges of screen fonts."

  6. Select the "ClearType" option.

  7. Click Apply & Re-open your Chrome browser.

From now on Chrome will render your fonts nicely anti-aliased for that smooth effect.

share|improve this answer
2  
This worked for me, slightly different options on Windows 7 though –  Gearoid Murphy Aug 26 '12 at 17:13
2  
It works without restarting chrome. –  iamcreasy Apr 16 '13 at 2:52
    
It didn't work for me on XP until I restarted Chrome. –  ashes999 Aug 15 '13 at 2:05
add comment

Do you have GPU Acceleration enabled in Google Chrome? Type about:flags and look for GPU Accelerated Canvas 2D, Disable it if enabled. Fonts on some sites appear really jagged when I browsed with the acceleration enabled.

share|improve this answer
    
I used to have it enabled myself, but after version 10 the font-rendering took a hit. I'm hoping Google will address the issue at some point. –  red Jul 12 '11 at 6:33
    
It was disabled. I tried temporarily enabling it just to see what would happen, and noticed no difference. –  hughes Jul 12 '11 at 13:21
    
Alright. In case you manage to find what was wrong, remember to update here. –  red Jul 12 '11 at 13:31
    
In my case, disabling GPU acceleration fixed the aliasing. –  kcbanner Jul 2 '12 at 16:51
add comment

Within Google Chrome click on the Wrench > Options > Under the Hood > [next to Web Content] click Customize Fonts.

Change your settings so that your page looks just like mineMy options screen

Then click the x, and see if your problem is fixed.

If this doesn't fix it, there might be one more thing... but I'll wait until you try this.

share|improve this answer
    
Already identical: i.imgur.com/zhTBS.png though you'll notice that even comparing our screenshots, the default fonts are very jagged on my machine. –  hughes Jul 12 '11 at 19:27
    
OK... who makes your video card? –  wizlog Jul 13 '11 at 4:57
    
Also... go to google.com/webfonts are all those just as messed up? I know that you went to typekit.com... but this may be different. Try to look through the different filters and see if your problem applies to all of them (ex. is it just serif or...) –  wizlog Jul 13 '11 at 5:02
3  
This changes the typefaces (the "fonts"). It has nothing to do with font rendering. –  Andres Riofrio Apr 28 '12 at 6:30
add comment

Chrome does not render web fonts well at the moment. There are several bugs on their issue tracker for this. Please star any relevant to you them to give them more attention.

share|improve this answer
add comment

I had exactly the same issue, rendering webfonts from http://www.google.com/webfonts in Chrome. I tried all the suggestions on this and a couple of other sites and none of them worked.

Eventually I began inspecting the CSS properties of the affected text, it turned out to the the actual font colour that was causing the issue. A title given color:#454545 would render badly, yet the same title given the following: color:#333 worked fine. Thank God for user agent specific style sheets!

share|improve this answer
add comment

In Windows XP, I just changed the anti-alias option from "Default" to "Clear Type" in
Display → Properties → Appearance → VisualEffects.

share|improve this answer
add comment

Chrome takes the system clearType value for fonts. Looking better in Windows 7 explains that. On a Mac, Anti-aliasing is enabled for all fonts above size 8, I suppose. Try turning on or changing the clearType of your Windows machine

Update: Seems like Chrome 22 and up ignore the System Settings for clearType

share|improve this answer
add comment

I had this problem so severely in Windows XP SP3 that it rendered Chrome unusable for all intents and purposes. I noticed that I had installed Clear Type Tuning in the Control Panel and tried unchecking "Enable Font Smoothing" in the advanced tab. After restarting Chrome. it was ok, even after turning Font Smoothing on again. I decided to check the box "Apply all settings to defaults for new users and system".

share|improve this answer
add comment

It looks like the long and hard answer is you can't. There are plenty of discussions and suggestions in Chrome help, but I don't see anything worth suggesting.

The big question is how are you getting it to look so bad?! I'm using Chrome to type in this box... I even zoomed in a whole bunch and I don't see anything like you are. If you still have questions after this you should explain out your configuration to the community.

share|improve this answer
add comment

Although Chrome is "useable" for the fonts, it looks thin and washed out where it renders diagonal lines especially. IE renders much better but IE is a slower browser and so it FireFox.

I believe this is inherent in the code for chrome.

BTW, HackToHell, where do I go to change the rendering color?

I'll try this.

share|improve this answer
add comment

press windows key + r then type cttune.exe in there

alternative method is to press windows key then type in cleartype then select Adjust ClearType Text

and follow the instructions, if you still have issues try some of the other examples

this worked for me, you have to try the different examples, its much like contrast/brightness calibration but for text instead

FYI: disabling 2d acceleration might help to get chrome to play with windows cleartype tune tool

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.