Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a problem with NTBackup on Windows XP (SP3). Every time I try to run NTBackup, it freezes when it says something like "Preparing to backup via Shadow Copy" (can't remember exactly). It just freezes and after waiting for 4 hours, I had to end the process. Why is this happening? I have tried several times to get it to work, but to no avail. It only fails when BACKING UP. I checked the event log, but there are no errors, warnings or messages relating to the backup. I haven't changed anything since upgrading to SP3, before the upgrade everthing was fine. What can I do to get NTBackup working without having to unistall SP3?

share|improve this question
In ntbackup, go to Tools->Reports, and post the report for one of the failed backups. – Dentrasi Aug 27 '09 at 19:37
The report is empty... (?) – Kryten Aug 28 '09 at 16:07

If it's NTBackup that is failing, you can try re-installing it. There are some places online where you can download NTBackup.msi. I'm not sure how much I trust some of the random sites but they're out there. Also, Windows XP Home Edition comes with NTBackup.msi on the install cd under [CD]:\ValueAdd\MSFT\ntbackup.msi.

The Windows XP Pro Install CD has NTBackup included as part of the i386 install folder. You'll need to expand the NTBackup files (Ntbackup.exe, Ntmsapi.dll, Vssapi.dll) individually to your System32 directory in order to restore the original application.

However, I'd actually recommend creating an NTBackup folder in Program Files and Expanding the files there instead. This process will prevent you from overwritting your current version of NTBackup, in case it's not currupted and you want to go back. Just keep in mind that if you do this then your original shortcuts to NTBackup still point to the old version and you'll probably want to create new shortcuts to the new location.

Assuming you 1) choose the program files option and 2) program files is on the C drive and 3) your Windows XP Pro CD is drive D and 4) you have already created the ntbackup folder under program files, the following commands should give you the results you need. To open the command prompt click the start menu and select Run. Type "command" ("cmd" works as well) and hit enter.

expand d:\i386\ntbackup.ex_ c:\progra~1\ntbackup\ntbackup.exe
expand d:\i386\Ntmsapi.dl_ c:\progra~1\ntbackup\Ntmsapi.dll
expand d:\i386\Vssapi.dl_ c:\progra~1\ntbackup\Vssapi.dll

If the new setup of NTBackup produces the same results as before then check the log files to determine which file was being backed up at the point of freezing and research the possibility of that file being corrupt or locked somehow.

share|improve this answer

It could be the volume shadow copy service which is corrupted, causing NTBackup to get stuck.

Drop into a command prompt and check for any VSS errors:

  1. Click Start
  2. Click Run
  3. Type cmd and press Enter
  4. Type vssadmin list writers and press Enter
  5. Check for any State: or Last error: which does not say [1] Stable or No error respectively. If you find one, this is a very good indication that VSS might be a little broken.

Do you see any errors?

Regardless of whether it mentions any errors, I would still do an 'sfc /scannow' next. This will hopefully fix any broken system files and may well fix the overall problem with NT Backup.

  1. Put in your XP installation CD and close the installation wizard that appears
  2. Click Start
  3. Click Run
  4. Type sfc /scannow
  5. Cilck OK
  6. Let it run through and restart
share|improve this answer

Recently troublshooting a backup error I checked the event logs that stated to check the backup report. I found this report in the NTbackup console under tools > report. It said "device not found".

My problem was NTbackup could not find the device even though it was attached and detected on the system. Upon viewing in the properties of the job in scheduled tasks tab under Run in the backup path I discovered the drive letter was incorrect.

I changed it to the corrrect drive letter and problem solved. Somehow the drive letter got changed when the user attached the second external USB drive.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .