Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is puzzling me from a while, if I use windows explorer to access a remote network share by IP it works fine, however it does not work if I use hostname

eg.

\\IP_address\c$  - works

\\hostname\c$ - does not work

from a command line I can ping the short/long hostname without any problems, I do have the windows "web client" service running, any thoughts on this ?

share|improve this question

1 Answer 1

Your software firewall is probably blocking File and Print Sharing (or at least ONE, but clearly not all, of the ports it uses). Go into your firewall properties and check it. You can also turn it off temporarily to test if that does not work.

enter image description here

Here is more on the ports used:

http://support.microsoft.com/kb/119493

One more thing to check is in your Network connection's properties. Make sure it is set to default, or enable NetBIOS over TCP/IP.

enter image description here

share|improve this answer
    
Disabled the firewall, had these settings in place and still nothing. It does not even work for localhost, I can \\127.0.0.1\c$, but can't \\localhost\c$ ! I've did ipconfig /displaydns and flushdns and worked fine, this is a bit odd. –  Tiberiu Hajas Jul 8 '11 at 17:47
    
That is very strange, ESPECIALLY for localhost not to work. I would consider resetting my TCP/IP settings with "netsh int ip reset" support.microsoft.com/kb/299357 –  KCotreau Jul 8 '11 at 19:01
    
still the same even after TPC/IP setting reset –  Tiberiu Hajas Jul 13 '11 at 2:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.