Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am forced to use Lotus Notes at work. I can disable most of the sounds it makes through it's horrifically bad preferences management, but there are a few sounds that appear to be impossible to disable.

That or they are buried. Due to the fact that I can't find a global "Lotus does not make a peep" option anywhere I think I'm forced to more drastic measures.

Is there a way to tell Windows 7 to not allow an application access to the sound subsystem? Conversely, technically Notes is a java application, so maybe I can force the JVM it uses to send all sounds to the void.

Or do I just have to suffer with the abomination of a mail client?

(Of note, every single 'event' in Lotus is set to not play sounds, so there are some events that play sounds that aren't events. Or something.)

share|improve this question

2 Answers 2

up vote 12 down vote accepted

On Windows 7, if you click on the volume icon, there is a link to "Mixer" where you can mute individual applications. It should stop once you mute java.

windows 7 sound mixer

share|improve this answer
    
I'm amazed at how many otherwise savvy users (the OP sounds pretty knowledgable, and since he accepted the answer I assume he falls into this category) still don't know this is here. The first time I found it I'm pretty sure angels descended from the skies, and then I told everyone I knew about it. –  Shinrai Jul 8 '11 at 17:49
    
You shouldn't need to disable it for java, Notes shows up in that list as Notes. Also, Notes uses java internally, but is a native application, it doesn't run using the regular java jvm that runs pure java programs and applets. –  Zach Jul 8 '11 at 19:38

I don't know that every application in will show up in that list as in the other answer. If not, create a very short, but silent wave file (you might be able to download one from somewhere too). Try to figure out where the file is located, which is making the sounds you don't like, and replace the unwanted file (rename it .old) with a renamed copy of your silent wave file.

It may take a little hunting, but you should be able to find them. Older programs like this usually have their own wave files in their own install sub-folders.

Of course, make sure it is not just in the Sounds Control Panel applet, where you can just disable it. I put this last since it sounds like you probably did check there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.