Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Laptop connects to wireless network but gets invalid ip?

I have two laptops at home , with WiFi. One laptop (Windows 7) is working fine, but the other laptop (Vista) has no internet. The configuration is same in both laptops (ie auto IP), only difference I found is in the network connection details:

Router:

dhcp : yes
IP : 192.168.1.1
DNS specified 

Windows 7 which works fine has:

dhcp enabled yes 
ipv4 address 192.168.1.34
subnet mask 255.255.255.0
ipv4 default gateway: 192.168.1.1 
ipv4 DNS server are same as in router

Vista has:

dhcp enabled yes
autoconfiguration ipv4 address 169.254.206.5
subnet mask 255.255.0.0
ipv4 default gateway <blank>
ipv4 DNS server <blank>

Can anybody tell me how to make the Vista laptop in the same IP range and get the internet.

share|improve this question

marked as duplicate by William Hilsum, studiohack Aug 1 '11 at 1:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Are they both connected to the same network? Have you restarted the wireless router? –  music2myear Jul 8 '11 at 22:08
1  
Check that all devices are running the same WIFI protocol (a/b/g/n). –  dbasnett Jul 8 '11 at 22:13
    
both the laptops are in same network , and run in 802.11b –  narayanpatra Jul 8 '11 at 22:29
    
that was one hell of an edit –  MaxMackie Jul 8 '11 at 23:03
    
now the problem is clear , plz help to troubleshoot –  narayanpatra Jul 8 '11 at 23:04
show 1 more comment

2 Answers

A 169 IP indicates that the Vista machine isn't receiving a valid IP response from the router. The reason for this can be varied, but boil down to:

  • DHCP request from the Vista machine isn't reaching router
  • DHCP response from the router isn't being recognized by the Vista machine

The reason for these two things could be any number of network related issues, from the wifi key not being correct, to a problem with the DHCP functionality of the Vista machine.

Connect the Vista machine directly to the network via CAT5 cable, if it works fine, then probably a problem within the wifi network connection on the laptop. If it doesn't work, then more likely a problem with the DHCP functionality of the laptop (which could still be wifi key related).

In XP you can delete the wireless connection (not the wireless network adapter, but merely the "wireless network" as seen in the available networks) and then reconnect to it, allowing you to re-enter the key. I'm sure you can do something similar in Vista, so you should try that to ensure the key doesn't have a typo.

You could also try hard coding the IP address as something like 192.168.1.42, other network settings (Netmask, DHCP, etc.) should be same as Win7 laptop. Unfortunately, I don't know how to hard code IPs on Vista. If it still doesn't work after hardcoding the IP, it could still be the key, but beyond that I'm out of options to try.

share|improve this answer
add comment

You can try assigning a static IP. It does not help troubleshoot your issue but may allow you to access the internet on the Windows Vista Laptop.

  1. Go To "Network and Sharing Center"
  2. Click on "Change Adapter Settings" (Left hand column)
  3. Double click on your wireless adapter connection
  4. Click on "Properties"
  5. Double click on "Internet Protocol Version 4 (TCP/IPv4)"
  6. In the "General Tab" select the radio option "Use the following IP address:"
  7. Assuming 192.168.1.35 is not in use, type that in the "IP address:" field
  8. Set the "Subnet mask:" to 255.255.255.0
  9. Set the "Default gateway:" to 192.168.1.1
  10. Select the radio "Use the following DNS server addresses:"
  11. Set the "Preferred DNS server:" to 192.168.1.1 12 "Okay" and "Close" out of all the windows.

If 192.168.1.35 is taken by another machine or device, you can try 192.168.1.36 and so on.

You can always go back to your default settings by choosing "Obtain an IP address automatically" and "Obtain DNS server address automatically" in the TCP/IPv4 properties screen.

Follow Steps 1- 5 top get to that screen.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.