Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to test (or "Run"...) my WebMatrix website (PHP) (IIS Express), only Opera works.
All other browsers refuse to connect to the server ("http://localhost:55555/", for example).

Internet Explorer 9 says

This problem can be caused by a variety of issues, including:
•Internet connectivity has been lost.
•The website is temporarily unavailable.
•The Domain Name Server (DNS) is not reachable.
•The Domain Name Server (DNS) does not have a listing for the website's domain.
•There might be a typing error in the address.
•If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

So, basically, it just doesn't work.

Firefox, on the other hand, is a little more dumb:

The connection has timed out

          The server at www.localhost.com is taking too long to respond.

  The site could be temporarily unavailable or too busy. Try again in a few
    moments.
  If you are unable to load any pages, check your computer's network
    connection.
  If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.

First of all, it tries to change my "localhost" no matter what...

Google Chrome is too shy to explain me the problem:

Oops! Google Chrome could not find localhost:55555

I couldn't expect more...

Safari, on the other hand, did better than I ever expected.

Safari can’t open the page “http://localhost:55555/” because Safari can’t find the server “localhost”.  

So, what can I do about this?
How can I test my WebMatrix website with other browsers?

Edit: Apparently, bumping... What is there not to understand? Please ask for more info if you need and I will give.

Important!
Edit2: This THING happens on my brother's laptop (which I use most of the time) and my desktop.
It does not happen on my netbook.
On my desktop and my bro's laptop, we have Opera as our default browser and IE9.
On the netbook, I have Chrome because it starts faster and IE8.

Can the update to Internet Explorer 9 cause this?

One more thing I noticed when opened in IE8 is the Intranet Settings option, which I cannot find in IE9.

share|improve this question
    
Those errors would suggest your IIS system is not running on port 55555 if you view local host for port 80 do you see the IIS pages? Have you checked the settings on the server to ensure port 5555 is open and ready? Opera could be doing something clever like defaulting back to port 80 if the other one fails. –  Jane T Jul 10 '11 at 10:05
    
You have never used WebMatrix, have you? IIS Express works on whatever port I tell it to. If I open just "localhost", with no port or port 80 IIS says "not found" (404) (on Opera) while other browsers tell me the same errors. –  Vercas Jul 10 '11 at 10:13
    
@Jane T: Usually when using WebMatrix iis express will automatically be assigned a random port, Vercas here has set his own port though! –  sinni800 Aug 2 '11 at 10:51
    
Also a question from me: All 3 PCs have the same version of Webmatrix and IIS installed? –  sinni800 Aug 2 '11 at 10:56
    
@sinni800 Yes! Also, the port is GIVEN RANDOM FIRST TIME. You can change it anytime you want in WebMatrix! –  Vercas Aug 9 '11 at 18:47

1 Answer 1

First let's see if it is actually running off port 55555. Try:

netstat -a | find "LISTENING"

You should see an entry on port 55555. If it is in fact running your service. In any other case, open a browser and try http://127.0.0.1:55555 instead of using localhost. Most of the time this isn't an issue, but it's best to cover our bases.

If that still doesn't work, my suspicion is a misconfiguration of the service itself. Another option, if you can't get this to work is to set up an Apache web server instead of using IIS.

share|improve this answer
    
0.0.0.0:55555 is there. Edit: And [::]:55555... –  Vercas Jul 10 '11 at 14:02
    
When I try to access http://127.0.0.1:55555/ on any browser I get a 400... HTTP Error 400. The request hostname is invalid.. From this I can conclude that other browsers treat localhost as something else. –  Vercas Jul 10 '11 at 14:13
    
Since when pinging is done on ports? Nothing works anyway... (tried - cannot find hosts) –  Vercas Jul 10 '11 at 15:07
    
Wow yeah, sorry about that. I meant try to get something via telnet. –  maxmackie Jul 10 '11 at 15:11
    
I have no clue what and how... –  Vercas Jul 10 '11 at 15:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.