Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Windows 7 PC. When copying a movie file (mp4) from a DVD to my PC's hard drive, in Windows Explorer, I'm getting the error:

Invalid MS-DOS function.

The error message pops up, I cancel out, and the file is not copied at all. I have many other mp4 files on the DVD (I custom ripped it), which copied just fine.

What does it mean? How can it be resolved?


Ok, it seems the file may be corrupt at the end of the movie file, as it causes VLC to hang and crash.

share|improve this question
Microsoft doesn't bother renaming ancient error messages? – Michal Kováč Jul 30 '14 at 19:09

As you confirmed that it is probably corrupt, that is good.

Usually it happens because the DVD is copy protected. There may be software that bypasses that, but it is doubtful someone would get that kind of help here as it is frowned upon.

share|improve this answer
I updated my question. The DVD contains other mp4 files which copied over just fine. The DVD is full of mp4 files I made a while ago. – spong Jul 9 '11 at 0:54
OK, I will update my answer then too. :) – KCotreau Jul 9 '11 at 0:55

I also received the "Invalid MS-DOS Function" error while copying files, but under a different circumstance: Windows 7, copying files from an SMB share on an Mac OS X Lion machine.

(This won't apply to you, but this is the only Super User question referencing "Invalid MS-DOS Function", so I mention it only in hopes of helping someone else!)

On the Mac, I opened a Terminal and ran ls -al in the affected directory, and noticed this:

drwxr-xr-x@  4 Blair    staff         136 18 Jan 21:52 Stuff

The @ mark is important -- it indicates that the file/folder has Extended Attributes.

This was the only folder I was having trouble copying; I checked all the other files and folders that copied successfully and discovered that they lacked extended attributes.

Running ls -al@ reveals what the extended attributes are:

drwxr-xr-x@  4 Blair    staff         136 18 Jan 21:52 Stuff            48

This is the quarantine attribute used by the OS to mark files downloaded from the internet as "potentially unsafe".

Believing the attribute to be playing foul with Windows, I decided to remove it. This answer shows how:

xattr -dr Stuff

I returned to the Windows machine and started copying the folder again -- it worked without a problem.

share|improve this answer
Absolutely the exact problem I had. Spot on, to notice the quarantine xattr. Great post! +1! – user16511 May 2 '12 at 15:55

You can delete the from by openning command prompt (windows start->cmd, click enter) then run: del \?[filename+path]

share|improve this answer

Though, I knew this was an old or probably a solved problem but here is my addition to the solution.

  • Click Start, type regedit in the Start Search box, and then press ENTER

  • Locate and then click the following registry subkey:


  • On the Edit menu, point to New, and then click DWORD Value.
  • Type CopyFileBufferedSynchronousIo to name the new entry, and then press ENTER.
  • Right-click CopyFileBufferedSynchronousIo, and then click Modify.
  • In the Value data box, type 1, and then click OK.
  • Exit Registry Editor.

Then copy.

share|improve this answer

I am late to this, but if someone is still looking for a solution: Copy command from the command prompt worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.