Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this 4-5 year old mainboard Asus M2N SLI Deluxe. Yesterday, I plugged in a usb stick at the front side of the computer casing, apparently in a defect port. The system froze, and now it won't boot, without beeps.

I've stripped all parts out of the pc (graphics card, RAM, hard disks, etc), except for the cpu and its fan.

When I turn the system on, the motherboard led lights up, the cpu fan spins, but nothing happens.

Is my motherboard dead, or is something else the problem (Is the board supposed to give no beeps

share|improve this question
    
You would need to put the RAM back in also. I would also keep the video card in to see what is going on on boot. –  KCotreau Jul 9 '11 at 16:08
    
I've tried putting in RAM four times: two different brands in two different slots (apart from eachother), still no beeps. Regarding the video card, I'm expecting beeps when the mainboard detects errors, eg the video card is missing. It is not giving those. –  Niek Haarman Jul 9 '11 at 16:21
    
Sounds very much like your MB is dead. Sorry. –  KCotreau Jul 9 '11 at 16:35
    
Yeah I was afraid of that. But wanted to be sure, would be embarassing if it's not broken and I find out after getting rid of parts ^^ Thanks anyway. –  Niek Haarman Jul 9 '11 at 17:39
    
In my experience the M2N SLI Deluxe is a very flakey board, prone to sudden failure. A couple of months ago I was working through a batch of 4 in-house machines sent back to IT Support as 'suspect' - all machines had an M2N SLI Deluxe motherboard - we scrapped 2 as faulty, killed one trying to reflash it and 'fixed' the last by swapping out the BIOS with one of the scrapped motherboards. –  Linker3000 Jul 9 '11 at 18:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.