Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am struggling with understanding permissions with FreeNAS.

I have a SMB share I would like to share with EVERYONE (it's just 1 box and my family). I want to enable read/write/execute for all users. How do I accomplish this without having to do a chmod? Possible?

share|improve this question

2 Answers 2

Set Authentication to Anonymous in CIFS/SMB|Settings and remove check from "Set read only" checkbox when you create a share. That should do. Though in FreeNas you cannot always get away with GUI setup only. In that case you can run "chmod" from Advanced|Command.

share|improve this answer

I am running FreeNAS as a VM. My permissions were not sticking.

I went to the FreeNAS server and opened a shell.

Run zfs list to find the path.

cd /PATH

Find the directory that needs changing.

Since I didn't have anything in that directory I was able to use a -R in the following for recursive:

chown -R nobody:nogroup directory

ls -l # to verify

Ctrl+d to get out.

Worked perfectly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.