Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I open regedit in Windows 7, I get

"Registry editing has been disabled by your administrator"

Can I open it someway in readonly mode? Or does anyone know how can I see values in the registry?

share|improve this question
    
This means your system administrator has disabled registry editing through Group Policy. The computer I'm using now is affected by said condition; using reg cmd tools does not work either. You will not be able to read or write to the registry – InterLinked Jul 5 at 13:36
up vote 6 down vote accepted

Non-administrators have the same registry 'read' rights as administrators.

You also have full write access (Full Control) to the HKEY_CURRENT_USER key.

To open the registry:

  • Open the Windows Start Menu
  • Type in "regedit" and press 'Enter' on the keyboard enter image description here
  • Workstations which are a member of a domain will prompt for a password - just enter the password for your non-administrator account. enter image description here

Please note:

  • Some sections of the registry are locked to all users (Admin or Non-Admin), for example HKEY_LOCAL_MACHINE\SECURITY

  • If your system is configured to disallow the use of 'regedit' you will need to speak with your system administrator. Giving advice on how to circumvent this would be unethical and likely against the superuser terms of use.

share|improve this answer

Use reg query in cmd. It does not need admin privileges.

share|improve this answer
    
And neither does regedit; it's a matter of group policy restrictions, which I assume both regedit and reg follow. – grawity Jul 10 '11 at 9:31
    
@grawity As a default, (and therefore for computers that are not part of a domain, and have no group policy set), reg query works, and regedit does not. – soandos Jul 10 '11 at 9:47
    
I've used regedit as a User on Windows 95, 98, NT 4.0, 2000, XP, Vista, and 7. – grawity Jul 10 '11 at 9:54
    
@grawity, I dont know what settings you were operating under, so I can't comment. In either case, my answer is not wrong, it just may not be needed. – soandos Jul 10 '11 at 9:57

Probably your administrator had disabled from group policy the right of opening registry editors.

Go to Run » gpedit.msc » User Configuration » Administrative Templates » System » "Prevent access to registry editing tools". Disable it or choose "Not Configured".

The main problem is that reg query doesn't work, giving the same error:

ERROR: Registry editing has been disabled by your administrator.

… or this sounds to me as a bug in Windows 7. On Windows XP, reg query is working fine, without any problem if "Prevent access to registry editing tools" is Enabled.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .