Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to run a command to fix a different issue, but when I cut and pasted the string there was a space in it and this is what was run:

sudo chmod 000 /System/Library/

Now when I try to open terminal, it just sits there with a blank screen and nothing loads. This started almost immediatey after I ran that command. Any ideas how to reverse this back to previous permissions? I did try repairing disk permissions, but that does not seem to have solved it. Thanks for any help.

share|improve this question

migrated from Jul 10 '11 at 9:07

This question came from our site for professional and enthusiast programmers.

Start your mac in single user mode. Than you get a commandline prompt where you can enter

chmod 755 /System/Library
share|improve this answer
Note that you'll first need to enter mount -uw / in order to get write access to the volume. – Gordon Davisson Jul 10 '11 at 8:41
@Gordon: oh yes, of course – Arne Burmeister Jul 11 '11 at 7:32

Open /System in Finder (Go - Go to Folder..), select 'Library' folder, Cmd+I, click lock icon to unlock settings (enter your pwd), set permissions.

share|improve this answer

You must log in to answer this question.