Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My workplace consists of computers running a variety of different operating systems, and I have been running into problems getting some of them to connect to a shared drive and printer over the network. Here is a brief description of the computers involved and the issues I have encountered:

1: Dell desktop, Windows Vista Business-- This is the computer I want the others to connect to. It has a USB printer and eSATA hard drive enclosure that I have set up for sharing, with different accounts for the various users.

2: Fujitsu laptop, Windows XP Tablet edition-- No problems. Can connect to both the shared printer and hard drive.

3: Lenovo laptop, Windows Vista Business 64 bit-- No problems. Can connect to both the shared printer and drive.

4: Apple MacBook, OS 10.4-- Can connect to the shared drive, but not to the shared printer. I am aware that the printer issue is due to a known incompatibility between Vista and OS 10.4 and earlier with regards to Samba. It is not a big problem, however, as this computer can access a network printer.

5: Sony laptop, Windows Vista Home Premium-- Can connect to the shared printer, but not the shared drive. It can see computer 1 and its shared drive on the network, and appears to successfully log in to user accounts. However, if you try to access the shared drive, it says you do not have permission. I have tried both standard and administrator accounts, and none can access the drive from this computer.

6: MacBook Pro, OS 10.5 (there are two of these)-- Can connect to the shared printer, but not the shared drive. They can't see computer 1 on the network. For that matter, they also can't see each other or the older Mac, but can see and access shared folders on the XP machine (computer 2) and can see other PCs in the building. I was able to add the shared printer manually by typing in its network location, but was unable to manually add the shared drive in the same way.

So, what I am looking for is suggestions on how to get computers 5 and 6 to connect to the shared drive. Since they can already connect to the shared printer (which is on the same computer as the shared drive), it seems reasonable that they should be able to access the drive as well.

share|improve this question
    
Since they're all using Samba, I assume they've been set to the same Workgroup? –  jweede Aug 27 '09 at 19:01
    
They are in different workgroups, but putting them in the same workgroup doesn't help. The MacBook Pros can't even see other Macs within the same workgroup as them, whereas they can see and connect to other Windows PCs even in a different workgroup. –  DanZ Aug 28 '09 at 17:10
1  
Are they all on the same subnet? –  John T Oct 24 '09 at 3:08

2 Answers 2

For printers the one thing I've found work from all modern OSs is IPP, such as is provided by CUPS.

For the file server, what OS is it running? I've had success with providing native AFP services to MacOS X and CIFS to Windows from the same host.

share|improve this answer
    
The only problem with providing AFP from a Windows Server is that unless you shell out for something like Extreme-Z IP, you're limited to an older version of AFP that doesn't do things like long file names. Being limited to 31 characters for a file name quickly gets infuriating for your Mac users. Also, LPR for printing is an option if the server doesn't allow for IPP sharing or if you have problems with it. –  afrazier Jan 24 '11 at 15:54

You need to try the following:

On your Vista Business Machine, look in: Local Security Policy->Local Policies->Security Options

Set these options to be disabled:

Microsoft network client: Digitally sign communications (always) Microsoft network server: Digitally sign communications (always)

Also be aware that Vista Business will only allow 10 connection. I am not sure if each printer and share counts as a connection. If you need more than 10 you will have to migrate to server as opposed to a client.

share|improve this answer
    
Both of those options are already disabled. –  DanZ Aug 28 '09 at 17:05
    
And you have the firewalls set to allow, or just turned off on the internal net? –  pulcher Sep 1 '09 at 5:55
    
Vista SP1 took out the connection limit. –  surfasb Jul 12 '11 at 21:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.