Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I accidentally removed the power management program in the System > Preferences > Startup Applications panel and ever since I have had to go to System > Preferences and then run Power Management just to see my battery life remaining.

How do I turn this feature back on at startup?

share|improve this question

2 Answers 2

I have Ubuntu 10.04 in VirtualBox .If I have the address correct this should work.
You can click on System > Preferences > Startup Applications >and in the Startup Programs tab click on the Add button, then browse to the File System Folder “/etc/xdg/autostart/gnome-power-management.desktop” click Open { this will enter the address in the Command Address space}. Startup Applications Preferences Snip

Type Power Manager in the Name space and then click on the Add button. This should return Power Management to the Startup Applications Preferences.
If you have removed it totally, you may have to use a live cd to load from.
If that does not work a less than desirable way is to click on the Options tab in Startup Applications Preferences. Having only the minimum apps running including Power Management and click on ‘Remember Currently Running Applications’ or ‘ Automatically Remember Running Applications when logging out’, the application should run the next time you logon.
1).In the Terminal enter gconf-editor click enter then in the left pane; expand apps, scroll down and expand gnome-power-manager and click notify.
A list of possible notifications will appear in the right pane.
Clicking on the options will bring up a description in the lower right part of the screen.
Also check - /schemas/apps/gnome-power-manager/notify(same editor).
2).You can open power management click on the 'general tab' then click on 'always show icon' if that has failed.
3).You can right clicked on power management and then 'add this launcher to panel' this at least will place it on the panel.
Or from this link you can .....
Battery Status is available for Ubuntu 9.10, 10.04 and 10.10 via the following PPA:
•sudo add-apt-repository ppa:iaz/battery-status && sudo apt-get update
•sudo apt-get install battery-status
The applet will, initially, run as a standard gnome applet. To intitate ‘indicator applet’ mode you will need to run the following command in a Terminal : -
•/usr/lib/battery-status/battery-status --indicator
this information came from,
http://www.omgubuntu.co.uk/2011/01/the-omg-guide-to-must-have-indicator-applets/
and more infromation
http://www.omgubuntu.co.uk/2011/02/battery-applet-status-ubuntu/
1)'s information came from...
http://ubuntuforums.org/showthread.php?t=1050875
Hope one of these works for you.

share|improve this answer
    
I tried everything except the live cd option. None of them worked. I still have to manually run power management to see the battery remaining indicator. Thanks for the leads though :) –  Jeune Jul 12 '11 at 4:39
    
@Jeune-I have added some other options - from 1). to 'hope this helps' –  mic84 Jul 13 '11 at 0:27
    
Ok I'll try this out today. Will get back to you. –  Jeune Jul 13 '11 at 2:27
    
@Jeune, sorry found another poss, have placed it in as '1)' –  mic84 Jul 13 '11 at 2:49
    
Nope #1 didn't work. I am pretty sure installing Battery Status will solve my problem but that's not what I want for now. Most of your suggestions have to do with putting back the icon but I think the problem is, the power management process is not starting during startup. I know because before when I unplugged my laptop, the light becomes dim. Now I have to turn on power management manually just so the light will become dim. –  Jeune Jul 14 '11 at 15:33
up vote 0 down vote accepted

I was already able to solve this by going to System > Preferences > Startup Applications. I clicked on Add and then placed this command into the command field:

gnome-power-manager --verbose --no-daemon

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.