Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I copied a directory from a Windows server into the defined document root of my MacBook's installation of Apache. However, the file permissions are wrong. I've tried setting both the user and group to _www using Terminal, but the details in Get Info looks a bit wrong.

For example, this is what's currently showing:

What's currently showing

And this is what works on other files contained in my document root:

What I want

Why does the files/folders from the Windows server only have two rows in the Sharing & Permissions section? And how can I add _www as a group so I (Martin) can view and edit files, but Apache (_www) can still view and serve them too, like my other files?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

I've solved it. I ran the following commands:

sudo chmod ug+w .

This gave a group (which somehow set itself to _www) write permissions. Then:

sudo chmod -R 775 .

This gave me and _www read and write permissions, and everyone read permissions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.