Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My PC occasionally blue-screens (about once/wk). The error is displayed very quickly (too fast for me to catch), so I look for DUMP files.

After blue screening today, I checked my whole system for files that end with a *.DMP extension. The only one created today was this one:

C:\WinNT\MEMORY.DMP

...and this file had a zero byte length (was empty.)

How can I identify what the problem is in hopes of being able to resolve it? Is there some othe place to look for log info? Whe n I checked my system event log, I see the following error which happened around the time of the blue screen, but I am thinking that this is a non fatal error:

The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID 
{24FF4FDC-1D9F-4195-8C79-0DA39248FF48}
 to the user NT AUTHORITY\SYSTEM SID (S-1-5-18).  This security permission can be modified using the Component Services administrative tool.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Suggestions on where to go from here? I'm on SP2.

share|improve this question
    
There's a setting somewhere for selecting the amount of detail to log during a blue screen.. You should poke around your System settings for that, more detail can't hurt. Is there anything useful in Event Viewer? Your system is fully updated, right? –  Doc Jul 11 '11 at 16:42
    
First, disable the Automatically reboot setting. It's in the System panel (accessible with Win-Break) on the same tab as Environment Variables. It's easy enough to find. Next, open BlueScreenView and post a screenshot with one of the relevant dumps highlighted. –  Hello71 Jul 11 '11 at 16:46
    
@Hello71, Automatically reboot setting will have no effect on minidump generation. –  A Dwarf Jul 11 '11 at 17:17
    
+1 - (about once/wk) –  maxmackie Jul 11 '11 at 18:05

2 Answers 2

up vote 2 down vote accepted
  1. Right-Click My Computer and choose Properties.

  2. Go to the Advanced tab and click the Settings button under Startup and Recovery.

  3. Under the Write debugging information section, select one of the dump file options, from the dropdown box. "small memory dump" is all you need 99% of the time.

  4. Make sure they are being saved to %systemroot%\Minidump.

  5. Pagefile has to be enabled for a dump to be written to the disk, if it is not enabled, then the other settings will not generate a dump and write it to the disk.

This sets your system to generate a minidump file every time it BSODS to C:\Windows\Minidump (assuming C:\Windows is where your Windows XP is installed.

I suggest you create the %systemroot%\minidump folder if it is not already present.

Reboot to take effect.

share|improve this answer

Your system is rebooting automatically upon failure. To change this behaviour so that you can see the blue screen error (the system will then wait indefinitely for you to reboot it manually), follow these steps:

  1. Right-click on "My computer"
  2. Select "Properties"
  3. Activate the "Advanced" tab
  4. Click on the "Settings" button immediately below the "Startup and Recovery" heading
  5. Disable the "Automatically restart" checkbox below the "System failure" heading

Since it's unclear whether a reboot is required to make this setting take effect, you may wish reboot after changing this setting to be sure that it takes effect.

enter image description here

share|improve this answer
2  
Just to be clear, the "Automatically restart" option has no effect on the system ability to generate minidump files. They will be generated regardless of this setting, as long as they are properly set up in the "Write debugging information setting". –  A Dwarf Jul 11 '11 at 17:14
1  
Up-voted. Thank you. –  Chad Jul 11 '11 at 19:48
    
@A Dwarf: Thanks for pointing that out (+1). In looking at the options there, might be a bit unclear to some because there isn't a checkbox next to it to enable/disable it. –  Randolf Richardson Jul 12 '11 at 20:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.