Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While I am a Linux user I tend to be largely a GUI computer user in Linux. I use Fedora 12 and Firefox Web Browser. Firefox 2098.

Firefox works fine excepting one problem which I'll describe now.

When I attempt to open a Link which a friend or Company has sent to me, the Link will not open. I get the following message on a small screen when I attempt to open a Link:

Failed to execute child process "/usr/lib/firefox-3.5.4/firefox" (No such file or directory)

If I right click the Link I am offered the option of "Copy Link Location". I copy the Link Location then I go to my web browser – which is Firefox – I Click on "File/Open Location" and paste the Link Location and link opens just fine.

Is there a workaround for this problem?

share|improve this question
    
Hi William. I have removed your email address from your post. You seem to have posted an email-formatted message here and so everything's all over the place. I have done a general tidy up but in future it's best to type in your message from scratch rather than cutting and pasting in a structued format from another app. You have also referred to 'Firefox 2098', which does not exist and this may be why you are having problems with your question - have a check of your system and make the necessary edits to your text above. –  Linker3000 Jul 11 '11 at 18:43
    
@William - what Window Manager are you using? Gnome? –  Doc Jul 11 '11 at 18:54

1 Answer 1

The key to answering this question is likely "What application is the link you're opening located within?"

Application Level Fix

That application most likely has a setting somewhere for how to handle URLs. It sounds like your settings are calling on firefox, expecting it to be available from a location where it's not.

Window Manager Level Fix

If the application doesn't offer an obvious means of managing URL clicking functionality, then settings from your Window Manager may be getting inherited/used. Check your Window Manager's configuration for default web browser settings.

Command Line Fix

Failing the above two, I think you can probably just do the following to resolve your issue at the command line:

sudo mkdir /usr/lib/firefox-3.5.4; sudo ln -s `which firefox` /usr/lib/firefox-3.5.4/firefox 
share|improve this answer
    
I'm out of my league. I sent threee versions ofmy letter before the Moderator told me how have the question accepted. ON the final version I sisn't include Firefox 2098---but it appeared in the accepted version anyway. I do use Gnome. I don't know how to check my Window Manager's configuration for default web browser settings. –  William H. Ferguson Jul 11 '11 at 23:35
    
@William: What window manager are you using? Gnome? KDE? XFCE? –  Doc Jul 11 '11 at 23:38
    
William here again. I use Gnome as Window Manager. In desparation I ran the command White Phoenix gave me, just above, and it was accepted. I haven't received a "Link" to test the command as yet. –  William H. Ferguson Jul 12 '11 at 0:54
1  
7-13-2011 The Commandline command White Phoenix gave me yesterday solved my problem perfectly. Here's my thanks and Salute. –  William H. Ferguson Jul 13 '11 at 22:05
1  
White Phoenix' answer is ACCEPTED –  William H. Ferguson Jul 16 '11 at 2:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.