Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Fedora 15 on a notebook, however when I plug in an external LCD monitor the resolution can only be set to 1024x768 or 800x600.

This is what I know about the problem so far:

  • the notebook has Intel HD Graphics and Nvidia GeForce 310M
  • processor is Intel i3 M370 @2.4GHz
  • attempting to install drivers for the GeForce caused GNOME3 to fail to load (had to reinstall)
  • I installed Fedora from a Live CD
  • the LCD monitor appears as "Unknown monitor" to the system

How do I get more options to change the resolution?

lspci:

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Device [1043:1362]
    Flags: bus master, fast devsel, latency 0, IRQ 45
    Memory at d3400000 (64-bit, non-prefetchable) [size=4M]
    Memory at b0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at e080 [size=8]
    Expansion ROM at  [disabled]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [a4] PCI Advanced Features
    Kernel driver in use: i915
    Kernel modules: i915

01:00.0 VGA compatible controller [0300]: nVidia Corporation GT218 [GeForce 310M] [10de:0a70] (rev a2) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Device [1043:1362]
    Flags: fast devsel, IRQ 16
    Memory at d2000000 (32-bit, non-prefetchable) [disabled] [size=16M]
    Memory at c0000000 (64-bit, prefetchable) [disabled] [size=256M]
    Memory at d0000000 (64-bit, prefetchable) [disabled] [size=32M]
    I/O ports at d000 [disabled] [size=128]
    Expansion ROM at d3000000 [disabled] [size=512K]
    Capabilities: [60] Power Management version 3
    Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [78] Express Endpoint, MSI 00
    Capabilities: [b4] Vendor Specific Information: Len=14 
    Capabilities: [100] Virtual Channel
    Capabilities: [128] Power Budgeting 
    Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 
    Kernel modules: nouveau, nvidiafb

xrandr:

Screen 0: minimum 320 x 200, current 2390 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 293mm x 164mm
   1366x768       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1024x768+1366+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

xvinfo:

X-Video Extension version 2.2
screen #0
  Adaptor #0: "Intel(R) Textured Video"
    number of ports: 16
    port base: 76
    operations supported: PutImage 
    supported visuals:
      depth 24, visualID 0x21
    number of attributes: 3
      "XV_BRIGHTNESS" (range -128 to 127)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_CONTRAST" (range 0 to 255)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_SYNC_TO_VBLANK" (range -1 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
    maximum XvImage size: 2048 x 2048
    Number of image formats: 5
share|improve this question
    
Hmm, you should have either the Intel or Nvidia graphics, not both. But, we can verify which and take a look at some other things at the same time. Please plug in your external monitor, then locate Terminal in Applications, run it, and enter each of the following commands, pressing Enter after each one: lspci -vnn then xrandr and xvinfo Then, copy and paste the output in an edit to your post. –  Patches Jul 12 '11 at 3:14
add comment

1 Answer

up vote 0 down vote accepted

You can try setting your resolution to the desired level manually.

First, run this command, changing the example 1920x1080 resolution to the resolution you want:

cvt 1920 1080

That will spew out something like this:

# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

We're only interested in the chunk after the quotes and before the -hsync, e.g.

173.00  1920 2048 2248 2576  1080 1083 1088 1120

Use that in the next command to add a graphics mode:

xrandr --newmode clever_name 173.00  1920 2048 2248 2576  1080 1083 1088 1120

Now, add your new mode to your VGA output:

xrandr --addmode VGA1 clever_name

Finally, switch your VGA monitor to use it:

xrandr --output VGA1 --mode clever_name
share|improve this answer
    
worked perfectly, thanks –  user35356786 Jul 14 '11 at 20:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.