Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There seem to be a couple of problems at play here. First let me describe my set-up:

I have a Xubuntu 11.04 file server that I can SSH into. I believe that machine has all the packages it needs on it to make this work. I SSH in from an iMac running 10.6.8 (64-bit Kernel and Extensions).

That works fine.

In order to make the sshfs bit work I've installed MacFUSE. This excellent project seems to have been abandoned unfortunately. In any case, there was a problem with MacFUSE-2.0.3,2.dmg as it is 32-bit. I've updated to the 2.15 beta but that's still 32-bit as you can see (I think it has a 64-bit prefPane???):

MacFUSE

Now I need the sshfs 'plugin' to complete this picture. A typical terminal error message looks as follows:

error

I've tried using MacFusion but that didn't work either. I've also tried the sshfs.app. I believe the problem lies in the 32-bitness of the MacFUSE system.

I could buy Xcode and compile FUSE and sshfs from source, but I'm looking for pre-compiled binaries if at all possible.

Any clues?

share|improve this question
2  
It's been about a year since I tried to get sshfs going on OSX, I tried for a few hours before rebooting in to Ubuntu and resuming use of my machine. Anyway +1 to the question. I sure hope someone actually gets it working on 10.6 and posts simple instructions to replicate. PS - I too was on a Core 2 machine - meaning 64bit. –  Doc Jul 11 '11 at 23:08
1  
Cheers. It's an absolute hair-puller. Tried for hours last night to get it going. Big shame because it'd be so good if it did work. Anyway, here's hoping someone has the magic spell required. –  boehj Jul 11 '11 at 23:35
add comment

1 Answer

Well, from the error messages the problem lies in that your shell does not have sshfs in PATH.

You can check your path with:

echo $PATH

and/or you can try to run it with full path like:

/path/to/your/sshfs .. and the rest of the params

Usually on *nix systems you can add to your path (assuming your shell is bash) by editing/creating this .bashrc file to your home directory.

I'm not sure do you have nano editor available, but any editor will do (Word is not and editor).

nano -w ~/.bashrc

add a line to that file

export PATH=$PATH:/path/to/your/sshfs/dir
share|improve this answer
    
Thanks very much for your answer. I'd love to confirm that this is the problem. I never thought of my path being the problem. Unfortunately I can't check if fixing my path helps because the Xubuntu box has bitten the dust and I'm on OS X 10.7 now. Perhaps someone else can try this out? FWIW: I bought a QNAP 2-bay NAS instead of having the huge fileserver. Thanks again for your input. Also, I might add that OS X has nano and most of the basic *nix tools available. –  boehj Jan 19 '12 at 3:57
    
Well, we use Qnaps a lot. And especially the Pro versions are nice. And one of the reasons I love them is that they have ssh server on by default (configurable from settings) and you can try using sshfs against qnap (no point normally unless you're on a headless server without nfs or smb clients) so. sshfs admin@YourQnapHost:/tmp /YourMOuntPoint –  Manwe Jan 19 '12 at 7:24
    
Yeh, they're lovely machines. I haven't seen the need to SSH in as everything is local, but I may, for curiosity, take a look at SSH, et. al support. Thanks again. –  boehj Jan 19 '12 at 8:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.