Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday, Windows decided Steam needed a compatibility setting to run properly and showed me an informative dialog that left me with no choice but to acknowledge this. Steam ran fine, until it needed to be restarted for a beta update.

Steam however doesn't like compatibility settings one bit.

C:\Program Files\Steam\steam.exe

Running Steam in Windows compatibility mode is not recommended. Please remove any Windows compatibility settings for all users under file properties for Steam.exe and restart Steam. Press 'Cancel' to permanently ignore this warning and continue.

[Ok] [Cancel]

However, Steam.exe has no such compatibility option enabled in the Compatibility tab of its properties. I must then guess that Windows enabled a setting that cannot be controlled from there.

I'd rather not shrug this off and fix this problem. How can I do that?

share|improve this question
add comment

1 Answer

up vote 9 down vote accepted

Found the solution here.

From withing the registry editor (Windows, regedit, Enter), navigate to:

  • HKEY_CURRENT_USER
    • Software
      • Microsoft
        • Windows NT
          • CurrentVersion
            • AppCompatFlags
              • Layers
From there you can find per-user compatibility settings. In my example I found a value named C:\Program Files\Steam\Steam.exe with data ELEVATECREATEPROCESS. Removing it fixed the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.