Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on a Quad-Core Intel Xeon Mac Pro. I did all the upgrades for Leopard and currently running at 10.5.8. I purchased the Snow Leopard 10.6.3 version installation DVD but it doesn't let me upgrade. My optical drive works fine but when I put the DVd in for Snow Leopard, after a few minutes the system pushes the DVd out and does not show up on the desktop. I tried to start up with the DVd also, holding down the C and got the same result, after a few minutes the DVD is out and no installation. What could be the problem? What can I do to install? Thank you for your help in advance.

share|improve this question

It sounds as though your disc was damaged. The best option to solve this is to simply return it to the store for a new one.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.