Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Dell Latitude E5510 running Windows 7, seemingly random disables the charger/adaptor. After unplugging the charger from the socket, waiting a few seconds and plugging it back in, it works fine (sometimes only for a few seconds, sometimes until fully charged).

This behaviour is not dependent on the adaptor (I tried a different Dell-adaptor) and is not displayed when the laptop is in sleep-mode or powered-off (it charges OK). I.e. the operating system/power management/... is actively disabling the charger (control-led on charger goes out).

Googeling on for this issue gives little help. A single post describes similar symptoms, with the diagnosis being that the charger was incorrectly seen by power management as a NIC, and disabled. No solution posted however.

Changing the power management settings however does not ameliorate the situation, and I do not know how to request a log of power management-related events on Windows.

Any suggestions on diagnosis/possible fixes are welcome.

share|improve this question

1 Answer 1

Try this:

  1. Disconnect AC
  2. Shutdown
  3. Remove battery
  4. Connect AC
  5. Startup
  6. Open Device Manager
  7. Click the plus (+) sign next to Batteries category, right-click all of the "Microsoft ACPI Compliant Control Method Battery" listings, and select Uninstall In the "Confirm Device Uninstall" dialog box, click OK. (it’s ok if you only have 1 of these).
  8. Click the plus (+) sign next to System Devices. Right-click the “ACPI Fixed Features Button" and select Uninstall. In the "Confirm Device Uninstall" dialog box, click OK.
  9. Shutdown
  10. Disconnect AC
  11. Insert battery
  12. Connect AC
  13. Startup
share|improve this answer
    
I followed the steps yesterday, and after some worrying start-up failures, Windows booted. Until now the disabling-behaviour has not manifested itself, thanks. Care to expand on what the problem was/these steps actually did? –  mhermans Jul 13 '11 at 17:09
    
In part Windows controls the battery charging when booted, not sure what gets corrupted or how, but the procedure re-installs the components and drivers for those ACPI entries. Seems to be a common problem in Windows 7 and notebook PCs. –  Moab Jul 13 '11 at 20:16
    
Unfortunately, the behaviour started again a few days later. I'm open for other suggestions... –  mhermans Aug 19 '11 at 8:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.