Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How to setup Windows to not put my external drive to sleep?

I have an HP Windows 7 box and a few various brands of external USB drives.

One major annoyance of this set up has been that these drives will go to sleep every ten minutes. That causes really annoying delays whenever I get a save dialog in an app or try to play a new itunes song as it waits for these drives to spin back up and reconnect. Sometimes it just locks up Windows.

Is there a way to prevent this? Maybe an open source app that can keep these drives awake while windows is?

share|improve this question

marked as duplicate by DMA57361 Jul 12 '11 at 16:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

Go into the Power Options in Control Panel, then click on "Change Plan Settings" for your plan, then there should be an option "Change advanced power settings", then look under the "Hard Disk" and "USB Settings" areas.

This one may not be the actual answer, but set your "Turn off Hard Disk after" to never (set 0), but I think the real one is to set "USB selective suspend settings" to "disabled" at least when plugged in...but maybe also when on battery if you are using it that way when it happens.

In response to your comment that it did not work, try this too. Go into device manager, to the USB root hubs, and turn off the save power option. Also try to do it for your disk too under hard disks (it may not have this option, but check anyway).

enter image description here

share|improve this answer
    
thanks! I'll start with the selective suspend option and will report back on the results! –  DA. Jul 12 '11 at 16:04
    
alas, neither of those worked. :( –  DA. Jul 14 '11 at 21:44
    
OK, then try also making sure that they are exempt from power management. I will add a scrrenshot to the answer. Although I am just having you check the USB hubs, check to see if you can turn off power management for the disk too. –  KCotreau Jul 14 '11 at 21:50
    
Thanks, KCotreau. I did check that and they were all unchecked. Bummer. Looks like it's perhaps what Moab suggests and that there's some firmware settings. –  DA. Jul 15 '11 at 14:49

Some enclosures have this setting in the device itself, my Seagate has software to control this and other firmware features.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.