Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Precision 490 running Windows 7 and a NVidia Quadro NVS 285 video card. I have two monitors, and my left is plugged into the cable marked "1" and the right is plugged into "2". Inside Windows both the NVidia Control Panel and the standard Windows Screen Resolution both identify each monitor correctly.

No matter how many times I fix it, when the system starts the appearance has monitor 1 to the right of monitor 2, and monitor 2 is set as the default screen. I can use the NVidia Control Panel and tell it to 'Restore Defaults', and it then goes to the correct configuration.

There is no virus or malware, so I'm stumped why the settings are wrong again when I boot. How can I keep this from happening?

share|improve this question

5 Answers 5

I've seen this problem numerous times and the steps seem subtly different for different machines, monitors and versions of Windows. I've even seen similar problems on Linux.

What I would suggest is:

  1. Stop extending the desktop to monitor 2.
  2. Unplug monitor 2's video cable and let Windows realise it's gone.
  3. Power down the machine.
  4. Power up the machine with just one screen.
  5. Let it boot, log in and then power down again.
  6. Power up the machine again, let it boot and log in.
  7. Plug monitor 2's video cable back in.
  8. Extend the desktop to monitor 2.

If you are lucky, the next time you start up, the screens will stay where you put them.

Under XP/Vista if that failed, I would try try deleting the monitor devices in device manager after step 2 (after showing hidden devices). Not sure if this will make a difference in Windows 7 however.

Finally, if that doesn't work, I would try plugging Monitor 1 into the other video port between steps 3 and 4.

share|improve this answer

Have you tried swapping the cables physically?

Of course you'll probably have to run through the nvidia control panel quickly to ensure its all correct, but then try rebooting and seeing if it sticks or swaps?

share|improve this answer

This may sound a bit extraneous, but if changing drivers did not help your issue, and you have a service running called: Windows Live Mesh remote connections service; try disabling it. That’s what finally worked for me!

share|improve this answer
    
Yep, the little guy is messing with screen positions and resolutions. Is there a supprot link somewhere about it? Can't find one. –  SandRock May 16 '12 at 7:27

I had the same problem...and it was very frustrating. Everytime I turned on the PC the lefhand display had jumped over to the right display... they had reversed. Changing the cables round fixed this until I restarted...same issue.

Even though the screen were identified as 1 and 2...with the desktop on screen one.

I followed the above solution and this still did not work for me.

BUT...if you go into your graphics settings...I use win 7 so right click on desktop and goto to screen resolution.

Do a 'detect' and make sure you have the screens on extend across then apply...then darg the monitor 1 into position on the left....within the graphics editor.

Then simply drag and drop the displays to be the right way round. So simple I never knew you could drag and drop them in this way.

Hope that helps.

share|improve this answer

I have also experinced monitor startup issues; removing Window Live Mesh (now defunct anyway) solved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.