Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason, when I issue PLINK.EXE by itself (no command line parameters) it always tries to connect to some remote host which I used in the past but I no longer use now.

How do I change it to default to a different host?

(I know about the -l hostname option but this isn't what I am interested in my particular situation)

UPDATE: Could this be related to the PuTTY cmdline-host-override bug?

Regardless, I need to find a way to workaround this. I can't recall how that older host got there in the first place, but there's got to be a way to change it.

Any ideas?

share|improve this question
up vote 1 down vote accepted

I found the answer!

Thanks to section 4.1.2 Loading and storing saved sessions:

  1. Open PuTTY Configuration
  2. Click the Default Settings line under "Saved Settings"
  3. Click the Load button
  4. Edit the Host Name (or IP address) edit box to change from the older host to the one you want.
  5. Click the Save button.


share|improve this answer
Nice, was not aware of that feature ;) If you are using Git, check out git-flow for advanced usage. – Sharken Jul 13 '11 at 23:54
ssvnc uses plink, having any not-blank default settings set in putty causes ssvnc to ignore the user's given host and instead connects to the default settings... clearing default settings made it work again. – flagg19 Mar 16 at 11:15

Below is the command-line help for PLINK.EXE v0.60. See full version here.

PuTTY Link: command-line connection utility
Release 0.60
Usage: plink [options] [user@]host [command]
       ("host" can also be a PuTTY saved session name)

Notice that you need to supply a hostname in order to run PLINK.EXE. So i am guessing you are clicking on a shortcut instead, which has been set up to run PLINK.EXE with a specific hostname.

share|improve this answer
Thanks. I am not running a shortcut. I double-click C:\Program Files (x86)\putty\PLINK.EXE and immediately receive a prompt login as: from that old host. There's got to be a way to replace it. – WinWin Jul 13 '11 at 18:35
BTW, the first paragraph in 7.1 Starting Plink is completely wrong. I am able to double-click on its icon to run it. See earlier comment. – WinWin Jul 13 '11 at 18:46
On Windows 7 i have Putty installed and i do not see any link to PLINK.EXE. Before you click, try instead to right-click and select properties. Check that the target is pointing to PLINK.EXE. – Sharken Jul 13 '11 at 18:49
It's not a link. This is 100% verified. It's an Application(.EXE) having the size of 282,624 bytes. Please note that I cannot use command line parameters because it needs to be used with git as described here: – WinWin Jul 13 '11 at 18:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.