Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A friend owns a MacBook (13-inch Late 2007), somehow he's managed to screw up all the function keys.

I've managed to reset the ones for dashboard, expose, etc but the play/pause/fast forward/rewind/increase volume/decrease volume don't work.

Any ideas as to what's happened here and how to fix it?

share|improve this question
add comment

3 Answers 3

up vote 3 down vote accepted

There's a couple of things:

  1. Apple Menu -> System Preferences -> Keyboard
  2. Untick "Use All F1, F2, etc keys as standard keys"
  3. Click "Keyboard Shortcuts"
  4. Click "Restore Defaults"

That should fix the problem.

Edit:

Some people suggest powering off the MBP, or resetting the SMC completely. Here's a forum thread which describes a similar situation.

Here's how to reset the SMC on most recent Apple Portables.

The SMC is responsible for some system IO functions, such as the trackpad, as well as power management functions. It's entirely possible that your keyboard isn't behaving because of this SMC.

Also, does this behavior occur under a new user account? If it does not, I would be inclined to trash any files from the first user's library related to keyboard - or simply migrate to the new user account, whichever is easier.

share|improve this answer
    
restoring defaults just mucks it up even more. dashboard is activated by the play button, etc. However I went in and changed what I could manually, all I'm left with now to fix are the play/pause, rewind, fast-forward, mute, decrease volume and increase volume. –  cust0s Aug 28 '09 at 10:07
    
Updated with some more information –  EvilChookie Aug 28 '09 at 16:35
1  
Out of curiousity, what was the actual solution (since there were a few things to try in my post) - was it resetting the SMC? –  EvilChookie Aug 31 '09 at 20:29
    
@EvilChookie, for me #2 was the big game changer. Thanks! –  Yar Sep 9 '11 at 19:27
add comment

Go to System Preferences and click Keyboard. There is an option to switch the behavior.

enter image description here

share|improve this answer
add comment

You can use the utility FunctionFlip to change the keys from Fn keys to special features. Maybe that can help fix the problem.

share|improve this answer
    
EvilChookie's answer above is the most likely. :-) –  hanleyp Aug 28 '09 at 1:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.