Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just installed Windows 7 RTM and setup Windows VPN to work office. It all works fine except, when the VPN is connected, regular web access stops working eg: local web browser can't connect to anything. Disconnect VPN and web works again.

I've tried re-ordering the priorities of network adaptors with no luck. I'm not sure where to look next. Any ideas?

share|improve this question

4 Answers 4

You need to disable the remote gateway option.

These instructions are for Windows XP, but they should be reasonably similar for your VPN connection:

  1. Right click the connection, and choose Properties.
  2. Click "Networking" Tab
  3. With TCP/IP selected, hit "Properties"
  4. Click "Advanced"
  5. Untick "Use default gateway on Remote network"

What this will do is forward all non VPN traffic to your internet connection, instead of attempting to use the internet connection at the remote end. This is turned on by default.

share|improve this answer
1  
Nuts, you beat me to it! –  Jared Harley Aug 28 '09 at 0:13
    
Right, but I needed the Wins thing to get name of work machines working. Thanks. –  cantabilesoftware Aug 28 '09 at 0:15
    
brilliant thing!! this helped me SOOO much! This is critical if you are remote desktop-ing from the net onto a VIRTUAL Guest machine which is in itself in a special 3rd party intranet VPN and the 3rd party VPN network blocks inbound 3389 (as mine did!) –  conners Oct 12 '12 at 18:03
up vote 5 down vote accepted

I solved this by:

  1. Opening properties for the VPN connection
  2. Clicking the networking tab
  3. Selecting Internet Protocol Version 4 (TCP/IPv4) and clicking properties
  4. Click advanced button
  5. On the IP Settings tab, turned off Use Default Gateway on Remote Network.
  6. On the WINS tab, entered the IP addresses of our WINS servers in the office.

Works perfectly now.

share|improve this answer
    
+1: Good thing to know about WINS. It's not always necessary, but it's good to know for other readers. –  EvilChookie Aug 28 '09 at 1:23

You need to stop using your work VPN as a default gateway.

Advanced TCP/IP Settings

In the system tray, click on your network icon, right-click on your VPN connection, and choose "Properties".

  • Go to the networking tab.
  • Select Internet Protocol Version 4 (TCP/IPv4)
  • Click the "Advanced" button in the properties window
  • Uncheck the "Use default gateway on remote network" box
  • Click OK, OK, OK

That should fix your problem!

share|improve this answer
    
Right, but I needed the Wins thing to get name of work machines working. Thanks. –  cantabilesoftware Aug 28 '09 at 0:14

Is the VPN redirecting ALL traffic? It is possible that it is actually working as intended and your office is blocking outgoing internet traffic on the VPN Network / Subnet.

The quickest way to test this is to try and see if you can access any intranet your office may have.

share|improve this answer

protected by studiohack May 3 '11 at 9:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.