Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having trouble accessing the Internet from my sheevaplug.

I recently purchased a sheevaplug and connected it to my Linksys WRT54G router. The sheevaplug never showed up in the list of dhcp clients (under Status -> Local Network → DHCP Clients Table), but I was able to guess what the IP address would be and connect to the sheevaplug by way of ssh from my laptop computer:

ssh root@

At the sheevaplug command prompt, I'm unable to ping Google:


I'm able to ping Google without any problem from my laptop computer, which is connected to the Internet through the same router. The sheevaplug is connected to the router through an eithernet cable, whereas my laptop is connect though wifi.

Any suggestions on how to configure my system so the sheevaplug can reach the Internet? Thank you!

share|improve this question
up vote 0 down vote accepted

If the plug is not showing up in the DHCP registry, it might not also be receiving dns info to resolve the name.

If you can statically set your DNS server on the sheevaplug, try (google's public DNS Server). You can also try pinging that directly and seeing if that works.

EDIT: With more research I found that the Sheevaplug is automatically set to ignore DNS servers from DHCP. Follow these instructions to start full DHCP:

The DHCP client is configured to ignore any DNS servers returned by the DHCP server and use instead, while there is no local DNS server. Consequently, you won't be able to connect to any hosts by name until you fix this. In order to fix it: Edit /etc/dhcp3/dhclient.conf and comment out or delete the line "supersede domain-name-servers;". Run "dhclient eth0". Try "ping" - it should work.


share|improve this answer
I would like to know how to get it to show up in the DHCP registry if possible. – Gwen Avery Jul 14 '11 at 0:42
@Gwen Updated my post with some info that might help. – Evan Jul 14 '11 at 0:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .