Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have to pointer devices (mouse and touchscreen). Their devices are /dev/input/mouse0 and /dev/input/mouse1, also they are combined into one on device /dev/input/mice. I want my system to separate those devices. I was trying to edit my xorg.conf file, by changing this line in mouse input device section:

Option "Device" "/dev/input/mice"

to this:

Option "Device" "/dev/input/mouse1"

and then reloading Gnome Display Manager:

service gdm restart

After this, system behaves like nothing happened. I am certain that xorg.conf is read on restart - if I write some rubbish into it (change identifier, for example) gdm fails to start. But all other edits have no effect - I event tried to delete the line which specified the device, and nothing happened.

What can cause such behavior? And how can I fix it?


Mouse input device section in xorg.conf:

Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Device" "/dev/input/mice" # tried removing this line, nothing happens
    Option "Protocol" "auto"
    Option "ZAxisMapping" "4 5 6 7"
share|improve this question

migrated from Jul 14 '11 at 1:23

This question came from our site for professional and enthusiast programmers.

The Option "Device" "/path/to/device" is mandatory, the GDM should fail when you remove it. Could you past the whole section here ? And there's no other InputDevice configured ? – woliveirajr Jul 13 '11 at 12:03
@woliveirajr - Just tried it again - it has not failed. Yes, there is keyboard configured. I'll post the whole section in a minute. – Rogach Jul 13 '11 at 12:08
Updated the post. – Rogach Jul 13 '11 at 12:10

1 Answer 1

up vote 1 down vote accepted

Take a look at this point

The driver can auto-detect the mouse type on some platforms. On some platforms this is limited to plug and play serial mice, and on some the auto-detection works for any mouse that the OS's kernel driver supports. On others, it is always necessary to specify the mouse protocol in the config file. The README.mouse document contains some detailed information about this.

From this site.

Also take a look at the second part of this answer about USB mice

share|improve this answer
Autodetection is cool. But still, why it ignores the "Device" option? – Rogach Jul 13 '11 at 12:21
perhaps something with the correct module (the touchpad one) not being compiled, or loaded... them it autoloads the first it finds. – woliveirajr Jul 13 '11 at 12:39
I solved my problem (calibrating the touchscreen) without editing xorg.conf after all. Thanks for you help anyway. – Rogach Jul 14 '11 at 5:20
@Rogach thanks for sharing your solution, maybe it help someone with a similar problem! – woliveirajr Jul 14 '11 at 12:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.