Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Background: I'm trying to do a long SMB to SMB network transfer on a computer running xubuntu, but I've encountered a very weird problem:

My computer loses its network connection after random amount (in range of 10-40min) of inactivity, and any user activity (even moving the mouse) brings it instantly back up. The computer is connected via ethernet cable, not WLAN. When the connection drops, it stops answering and also disappears from the client list of the NAT router after a while.

I tried running a script that automaticly mimicks user behaviour with xdotool, but that does not seem to work. I also noticed that it's not just network activity that stops - the script outputs an increasing number every minute, and when the computer drops off network I noticed that the number doesn't increase! The script and network activity continues as if nothing had happened when I move the mouse, press shift or anything.

I found are no BIOS options relevant to this, and there's no such features in xubuntu power management I know of.

The computer is a Compaq Presario 6540fi.

Question: Any ideas what might be causing my computer to behave like this?

I'm also interested in how I could hack around the problem?

share|improve this question
Possibly a driver issue. I don't have an answer, but maybe a pointer:… – TFM Jul 31 '11 at 18:07
I have a presario F500 that I'm trying to use for an always-on robotics thing, and I'm having the exact same problem as you. I've also noticed that grub waits if there's any network activity on boot. It sounds like a hardware issue common to presario laptops, and I was shocked to find this considering I didn't even include it in my search. It would be nice if there was a solution to the problem... can you provide an update, or have you been unable to fix it? – Matt Jan 14 '12 at 14:17
@Matt Well, I never did fix it in any sort of proper way. I ended up taping a mouse to a rotating tabletop fan, in order to complete a large data transfer (moving any relevant data away from the thing). After that I moved on to another computer. And if I have any say in it, I'll stay at a good distance from any others like it too... Weirdest thing I've ever encountered, and very comforting to hear I'm not the only one - proves I'm not going crazy. :) – Ilari Kajaste Jan 15 '12 at 18:08

Stuff like this is can be because of weird ACPI incompatibilites. Make sure you've applied any kernel updates, and make sure your BIOS is at its latest version. You also might try specifiying acpi=off as a "boot time parameter" to the kernel in GRUB to disable ACPI although I believe you'll lose the ability to put your system to sleep or power it off without pressing the button.

*If else fails, consider this (warning, this is weird): If physically moving the mouse prevents this from occurring, possibly you can attach your mouse cable to a CD tray with a piece of duct tape and set up a periodic eject command from a script. It'll probably take some imagination to arrange the mouse in a way where it will move reliably over a long period of time.

share|improve this answer
"you can attach your mouse cable to a CD tray with a piece of duct tape and set up a periodic eject command from a script". Weirdest suggestion ever, but does it belong to a tech site? – TFM Jul 31 '11 at 18:09
Probably not. I'm likely to edit that out. But the stuff about ACPI is valid. – LawrenceC Jul 31 '11 at 18:33
Attaching the mouse to a moving object is a valid outside-the-box hack to try to solve my actual problem - especially using scripted CD-tray activity is a rather clever idea, I think! But the weirdness of it should definately be noted in the answer in a "If all else fails..." -fashion. I'm saying this because (ahem) I in fact did end up duct-taping the mouse to a rotating table fan for the remainder of the file transfer. (Oh, and it was surprisingly easy to set it up as reliable by making the mouse only rock a bit.) But I of course do not consider this an actual fix for the issue! :) – Ilari Kajaste Aug 1 '11 at 13:41
@Ilari: The fact that you do not consider this an actual fix for the issue makes me happy! Come on guys, the CD tray trick is way outside the box. You have a software issue, and you want to tape stuff on your box to solve it? Maybe play some music to "him", in case he's feeling homesick? Or some soup? – TFM Aug 2 '11 at 7:44
@TFM However, taping the mouse to a moving object does work since automated mouse movements subverts the issue, while music would have no effect... unless, maybe, if the music had a loud enough bass to move the mouse. :) – Ilari Kajaste Aug 3 '11 at 5:51

Not a solution, but here's two ideas that crossed my mind when I read the problem:

  1. The computer is going to sleep. I never use any sleep/hibernate type features, so I don't know much on the subject.
  2. Lack of entropy. If your file transfer uses encryption, your random number generator needs a source of randomness (entropy). Sources of entropy include the timing of mouse movements & keyboard button presses (I believe timing of network packets is another source of entropy, but it might not because that can be manipulated by a malicious third party).

Hopefully one of these ideas will point you in the right direction.

share|improve this answer
1) It could be some sort of sleep thing, but the computer certainly isn't doing any sort of standard sleep/standby. Those I can trigger from the OS, and they don't behave like this weird issue. E.g. on sleep the screen and power shut down, which doesn't happen when this happens. Yes, the screen really does remain active, and the sudden halt of activity is completely transparent to me, unless I have the computer doing something which suddenly stops proceeding. That's why I only noticed it with this file transfer issue. 2) The system doesn't use encryption, but an interesting thought. – Ilari Kajaste Aug 1 '11 at 13:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.