Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I do ls -l I get

-rw-------  1 nifle None  17K Jul 15 01:48 .bash_history
-rwxr-xr-x  1 nifle None 1.2K Feb  9  2010 .bash_profile*
-rwxr-xr-x  1 nifle None 3.7K Mar 22 10:03 .bashrc*
-rwxr-xr-x  1 nifle None 3.7K Feb  9  2010 .bashrc~*
drwxr-xr-x+ 1 nifle None    0 Mar  6 17:31 .cpan/
drwxr-xr-x+ 1 nifle None    0 Jan  3  2011 .emacs.d/
 <snip>

How can I get the date/time format to allways be YYYY-MM-DD HH:MM insted?

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

Assuming GNU ls, from info ls "Formatting file timestamps":

`--time-style=STYLE'
     List timestamps in style STYLE.  The STYLE should be one of the
     following:

...

`long-iso'
      List ISO 8601 date and time in minutes, e.g., `2002-03-30
      23:45'.  These timestamps are shorter than `full-iso'
      timestamps, and are usually good enough for everyday work.
      This style is equivalent to `+%Y-%m-%d %H:%M'.

...

   You can specify the default value of the `--time-style' option with
the environment variable `TIME_STYLE'; if `TIME_STYLE' is not set the
default style is `locale'.

So put the following in your .bashrc or .bash_profile and you are all set:

export TIME_STYLE=long-iso
share|improve this answer
    
Added a little more info to your answer. –  Nifle Jul 15 '11 at 14:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.