Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed the latest FreeBSD 8.2 distro using Parallels Desktop. Problem: Whatever I type in the Bash/Shell it is not echoed on the screen. It's behaving like a password prompt. As soon I hit return it's displayed though. This is really annoying and I've no idea what to do.

share|improve this question
add comment

1 Answer 1

It sounds like it may be an issue with Parallels not capturing the keyboard input correctly. Try clicking on the VM to force capturing the mouse/keyboard, and see if that makes a difference. If that doesn't fix it, you can try using VirtualBox to see if it shows the same problem.

Just to let you know, FreeBSD uses csh as the default shell, not bash. You should be aware of this since some things are done differently, such as setting environment variables.

share|improve this answer
    
No it's not an issue with the keyboard input as it's captured by FreeBSD correctly. Mouse/Keyboard are assigned to the VM (clicked on it, otherwise I wouldn'd get any response). Keystrokes are just not seen while typing. As soon I hit return it's also seen on the screen. According to your tip I've also tried VirtualBox but there I had other problems with installation and stuff. Not sure what else to do. Thanks anyway. –  david Jul 20 '11 at 13:31
    
Ok... I've never run into this problem running FreeBSD in in a VM or directly, but I've never run it on Apple hw. If you have a FreeBSD dvd, you can use it in live mode by selectinf Fixit form the main installer menu, then choosing live filesystem from CDROM/DVD. This will at least allow you to bypass OS-X & Parallels to test your hw directly with FreeBSD. –  Joe Internet Jul 20 '11 at 14:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.