Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

Memorex USB 8GB drive that shows 0 B available. I don't know if it's mechanically broken or something is wrong with it.

Even disk part shows it as (See Disk 2)

enter image description here

Any ideas?

EDIT: The bios shows it as 2231 PRAM...

share|improve this question

marked as duplicate by DragonLord, Journeyman Geek Jan 31 at 3:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Does this answer help? superuser.com/questions/88509/usb-drive-not-showing-full-size It worked for me with a similar problem. –  sblair Jul 16 '11 at 0:25
    
It doesn't :-( bummer... –  Matt Jul 16 '11 at 0:45

3 Answers 3

up vote 3 down vote accepted

The No Media status is a very bad sign. It ususally means that the USB flash contoller chip has lost the connection(s) to the memeory chip(s) - a hardware problem.

Unless the data is very valueable (insert 4-5 figure number here) - then you can ask one of the specialist data recovery centers - you can only throw the stick away and get a new one.

share|improve this answer

I've run into this myself. Here's how I solved it when I saw the USB drive as a 2XXX PRAM device in Device Manager and it was missing from My Computer/This PC:

  1. In Device Manager, find the PRAM device. If it's missing, unplug the drive and plug it back into a USB 2.0 port. Once you find it in Device Manager, right-click, uninstall.
  2. Confirm as necessary so the device is uninstalled.
  3. Unplug the device, then plug it back into a different USB port. If you have a USB 3.0 port, use it now.

Result: the drive appears as a normal USB drive as it's supposed to. Format it at your earliest convenience.

I think this happens if you format the drive as an EFI bootable disk.

share|improve this answer

The "No Media" would bother me. Is it showing up in the Device Manager? Disk Manger? How old is it?

Assuming there was nothing critical on the disk, I would try this:

select disk 2
list partition
select partition 1
delete partition

Then create and format it again.

share|improve this answer
    
there is no partition on the drive to select :-( –  Matt Jul 16 '11 at 0:20
    
Then try selecting the disk in diskpart, and running "clean", and "recover". Then try to re-create the partition. Also run "detail", and see if is shows anything. –  KCotreau Jul 16 '11 at 0:27
    
Of course, I am leaning to it simply being bad. Maybe it has a long warranty. A lot of them do. I checked, most Memorex have a two-year warranty. –  KCotreau Jul 16 '11 at 0:35
    
At least if it is not under warranty, a new Kingston 8GB flash drive is only $13. –  KCotreau Jul 16 '11 at 0:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.