Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How to install using yum ? Because when I tried this :

yum install gcc gmake make libcpp libgcc libstdc++ gcc4 \
gcc4-c++ gcc4-gfortran subversion ruby ncurses-devel -y

Subversion did not install ,

I tried this:

rpm -q subversion

and the response was package subversion is not installed

I got the following response after the yum command:

root@server [/usr/local/src]# yum install gcc gmake make libcpp libgcc libstdc++ gcc4 gcc4-c++ gcc4-gfortran subversion ruby ncurses-devel -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.easynews.com
 * extras: mirrors.usc.edu
 * updates: mirrors.usc.edu
Excluding Packages in global exclude list
Finished
Setting up Install Process
Package gcc-4.1.2-50.el5.x86_64 already installed and latest version
No package gmake available.
Package 1:make-3.81-3.el5.x86_64 already installed and latest version
No package libcpp available.
Package libgcc-4.1.2-50.el5.x86_64 already installed and latest version
Package libgcc-4.1.2-50.el5.i386 already installed and latest version
Package libstdc++-4.1.2-50.el5.x86_64 already installed and latest version
Package libstdc++-4.1.2-50.el5.i386 already installed and latest version
No package gcc4 available.
No package gcc4-c++ available.
No package gcc4-gfortran available.
No package ruby available.
Package ncurses-devel-5.5-24.20060715.x86_64 already installed and latest version
Package ncurses-devel-5.5-24.20060715.i386 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package subversion.i386 0:1.6.11-7.el5_6.4 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Processing Dependency: neon >= 0.25.5-6.el5 for package: subversion
--> Processing Dependency: libneon.so.25 for package: subversion
--> Processing Dependency: libapr-1.so.0 for package: subversion
--> Processing Dependency: libaprutil-1.so.0 for package: subversion
---> Package subversion.x86_64 0:1.6.11-7.el5_6.4 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: subversion
--> Processing Dependency: libapr-1.so.0()(64bit) for package: subversion
--> Running transaction check
---> Package apr.i386 0:1.2.7-11.el5_6.5 set to be updated
---> Package apr.x86_64 0:1.2.7-11.el5_6.5 set to be updated
---> Package apr-util.i386 0:1.2.7-11.el5_5.2 set to be updated
--> Processing Dependency: libpq.so.4 for package: apr-util
---> Package apr-util.x86_64 0:1.2.7-11.el5_5.2 set to be updated
--> Processing Dependency: libpq.so.4()(64bit) for package: apr-util
---> Package neon.i386 0:0.25.5-10.el5_4.1 set to be updated
---> Package neon.x86_64 0:0.25.5-10.el5_4.1 set to be updated
---> Package subversion.i386 0:1.6.11-7.el5_6.4 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
---> Package subversion.x86_64 0:1.6.11-7.el5_6.4 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Running transaction check
---> Package postgresql-libs.i386 0:8.1.23-1.el5_6.1 set to be updated
---> Package postgresql-libs.x86_64 0:8.1.23-1.el5_6.1 set to be updated
---> Package subversion.i386 0:1.6.11-7.el5_6.4 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
---> Package subversion.x86_64 0:1.6.11-7.el5_6.4 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Finished Dependency Resolution
subversion-1.6.11-7.el5_6.4.x86_64 from updates has depsolving problems
  --> Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.6.11-7.el5_6.4.x86_64 (updates)
subversion-1.6.11-7.el5_6.4.i386 from updates has depsolving problems
  --> Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.6.11-7.el5_6.4.i386 (updates)
Error: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.6.11-7.el5_6.4.x86_64 (updates)
Error: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.6.11-7.el5_6.4.i386 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
share|improve this question

migrated from stackoverflow.com Jul 16 '11 at 4:24

This question came from our site for professional and enthusiast programmers.

    
according to the o/p subversion is already installed on your system. can you try svn command ? –  Vivek Goel Jul 16 '11 at 4:22

1 Answer 1

Your control panel provider has excluded some packages in yum so they don't overwrite their versions of the exact same packages. Never mind that they could just put their stuff in their own directories. But whatever. Complain to your control panel provider.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.