Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to eject the SD card which is generally always in my Windows 7 netbook using either the context menu or the "Safely remove hardware and eject media" icon the computer tells me it can't because the device is in use.

Using certain tools I found that it's LibreOffice that has some kind of lock on the SD card. I can kill soffice.bin or soffice.exe and I can eject the card.

This happens without me ever actively using LibreOffice. It's just some kind of background task or daemon or service etc.

Is there an option or setting in LibreOffice to change this behaviour? Or is it a known bug in LibreOffice? Or what else should I do other than killing the task?

share|improve this question
Is the "Quick Starter" activated? If so, just disable it (context menu option in systray, Menu Tools --> Options --> LibreOffice --> Memory). Does any of the paths defined point to the sd card? You can check this selecting Menu Tools --> Options --> LibreOffice --> Paths. – tohuwawohu Aug 8 '11 at 13:31
@tohuwawohu: Quick Starter was on. Must've been default since I never used OO very much and don't recall changing that option. None of the paths are set to the SD card though. They're all set relative to C: – hippietrail Aug 8 '11 at 14:21
hmm, maybe there's still an entry in the "recent documents" list of libreoffice pointing to the sd. There are different tools to modify or clear the recent documents list, for example the history manager extension. – tohuwawohu Aug 8 '11 at 14:42
@tohuwawohu: I would consider holding locks to recent docs a bug but it doesn't do that since it contains entries for my unattached USB stick (H:) with no problems but none for my attached SD (D:) – hippietrail Aug 8 '11 at 14:45
indeed, sounds like a bug. I hope disabling the quick starter did solve the problem. If not, i'm at a loss... – tohuwawohu Aug 8 '11 at 15:17

You must log in to answer this question.

Browse other questions tagged .