Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Arch Linux with KDE 4.6 and Firefox 5.0, and I had to install a GTK+ theme to make apps like Firefox look nicer.

Now, I have another problem—Firefox doesn't use font smoothing on sites, even though KDE itself uses font smoothing. I didn't see anything related to that in settings.

share|improve this question
    
tried ubuntuforums.org/showthread.php?t=849523 ? – Sathya Jul 16 '11 at 13:12
    
@Sathya It didn't work. I'm using Firefox 5 if that matters. – nyuszika7h Jul 16 '11 at 14:13
    
Try disabling hardware acceleration, if possible. – Hello71 Jul 28 '11 at 23:14
up vote 4 down vote accepted

I've solved the problem by removing ttf-ms-fonts and ttf-vista-fonts and installing higher quality fonts (ttf-ubuntu-font-family and otf-texgyre) from the AUR.

share|improve this answer

Does the article Enable Smooth fonts on Ubuntu Linux apply to your case ?

It is also possible that your problem relates to Bug 660448 - Subpixel antialiasing too strong/incorrect everywhere, which was marked fixed on 2011-07-05. If so, then a future version of Firefox will fix the problem. You could also verify against Firefox Nightly Builds.

share|improve this answer

If it is indeed only happening on certain fonts, you can create a .fonts.conf file in your home directory with the following:

<fontconfig>
  <match target="font">
    <edit name="embeddedbitmap" mode="assign">
      <bool>false</bool>
    </edit>
  </match>
</fontconfig>

You may need to regenerate your font cache and/or restart X for this change to take effect.

share|improve this answer
    
Unfortunately this didn't work, but I solved the problem—as you see in my answer. – nyuszika7h Aug 1 '11 at 10:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .