Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using VMware 7.1.2 in Windows 7 with Ubuntu 11.04 as a guest OS.

In the host OS (Windows 7), I can access the Internet without any problems but in the virtual machine I can't access the Internet.

I've tried the following but with no success:

  1. Use all methods of connecting to the Internet in "Virtual Machine Settings": Bridged, NAT, Custom; none work.

  2. Used cabled and wireless connections on the PC - neither of them work.

I've used Ubuntu in VMware for several months - previously the Internet was always accessible. Could the cause of this be because I upgraded to Ubuntu 11.04?

share|improve this question

migrated from Jul 16 '11 at 17:34

This question came from our site for professional and enthusiast programmers.

Have you tried to switch on windows network sharing (in adapter options) ? – user94321 Aug 16 '11 at 6:44
Do you get an IP in the guest OS from any of the connection methods (NAT or Bridged)? – Tarek Fadel Aug 16 '11 at 7:15
  1. Select bridged networking for the VM.
  2. Reboot the VM.
  3. Troubleshoot networking in the VM as if it were a real PC on your network that can't connect to the Internet. As an example:
    1. What does ifconfig -a say? Do you have a real IP address from your network? If you use static IPs, then go configure one for this VM in Ubuntu.
    2. Can you ping the host's (Win7) IP address from the guest?
    3. Can you ping the private address of your router or default gateway? 3d) Can you ping

It's likely something in your guests network settings changed, maybe it thinks you have a new network card, maybe name resolution isn't working, maybe some firewall settings changed.

share|improve this answer

Coud it be that DNS has been clobbered? Can you SSH into this machine locally, but not ping, say, Check /etc/resolv.conf and tell us what you have in there. Is it or something usable?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.