Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a bit slow PC here, so I decided to put Ubuntu 11.04 on it. It use to run Windows Vista on a resolution of 1280x1024, so both my hardware and monitor support it.

Now I'm on Ubuntu, but can only run 1024x768, and the screen is not that bright. Its like when you don't have the right drivers on a Windows machine. Now i'm new to linux, so I do not know what do do. I have an onboard Intel chipset i965.

Maybe this is some useful information, I read something about it on a forum: lspci

00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
03:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0)

Can someone please tell me how I can get the screen better?

saif@sodium:~$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
share|improve this question
    
Please post the output of xrandr. –  Patches Jul 17 '11 at 1:40
    
Have you checked Intel's site for a Linux driver? You could also check the repositories through Synaptic for non-free software to see what is available. It is possible that no driver for the Linux kernel exists, but you could look. –  Abraxas Jul 17 '11 at 2:09
    
Edited in the output of xrandr –  Saif Bechan Jul 17 '11 at 13:48
    
I have no clue how to add a driver to the system. Can you maybe supply any links to some guides how to do so. –  Saif Bechan Jul 17 '11 at 13:50

4 Answers 4

up vote 8 down vote accepted

You can try setting your resolution to the desired level manually.

First, run this command, changing the example 1920x1080 resolution to the resolution you want:

cvt 1920 1080

That will spew out something like this:

# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

We're only interested in the chunk after the quotes and before the -hsync, e.g.

173.00  1920 2048 2248 2576  1080 1083 1088 1120

Use that in the next command to add a graphics mode:

xrandr --newmode clever_name 173.00  1920 2048 2248 2576  1080 1083 1088 1120

Now, add your new mode to your VGA output:

xrandr --addmode VGA1 clever_name

Finally, switch your VGA monitor to use it:

xrandr --output VGA1 --mode clever_name

Now that that works, you can make it take effect every time you log in. To do so, create the following files somewhere:

fix-resolution.sh with what is called a shebang line and then the last three commands you ran that got it working before, e.g.:

#!/bin/sh
xrandr --newmode clever_name 173.00  1920 2048 2248 2576  1080 1083 1088 1120
xrandr --addmode VGA1 clever_name
xrandr --output VGA1 --mode clever_name

fix-resolution.desktop with the following contents:

[Desktop Entry]
Name=fix resolution
Exec=/usr/bin/local/fix-resolution.sh

Now, copy the files to the appropriate places on your hard drive and make the script executable. From a terminal:

cp fix-resolution.sh /usr/local/bin
chmod +x /usr/local/bin/fix-resolution.sh
cp fix-resolution.desktop /etc/xdg/autostart

This will run the commands that force your monitor to the proper resolution every time someone logs into your computer.

share|improve this answer
    
WOW! thats genius! It worked like a charm, a bit hard to figure out for newbies tho. +1 and answer accepted! –  Saif Bechan Jul 17 '11 at 21:59
    
Hey it works, but the settings clear every time I reboot the machine, the settings are not saved. –  Saif Bechan Jul 18 '11 at 0:59
    
@Salf: I added info on how to fix that. –  Patches Jul 18 '11 at 11:35
    
I tried your sample but it flickers and does nothing for example please see: gist.github.com/1241265 –  YumYumYum Sep 25 '11 at 22:32

Correction on the scripts listed above.

The fix-resolution.desktop file should read:

[Desktop Entry]
Type=Application
Name=fix-resolution.desktop
Exec=/usr/local/bin/fix-resolution.sh

Without the Type it wasn't executing on my machine. The path was also reversed and originally pointed to /usr/bin/local which is not where the file was located.

share|improve this answer
    
Thanks for pointing this out. I did has some trouble with is, but I hardly rebooted the machine so the problem was minimal. –  Saif Bechan Aug 12 '11 at 14:00

It works at the first time, then it creates a flicker on small upper-left part my LCD 1940 screen for 6 days, and now my screen is completely burnt! Smoke came out from my screen and now dead! It's very dangerous!

share|improve this answer

I had the same problem on Scientific Linux 6. Ii works after I removed "nomodeset" from kernel options. You can remove it permanently in /boot/grub/grub.conf or similar file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.