Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install GTK as a dependency of a dependency of Audacity. The first time I tried to do the usual configure-make-make install set of commands for it, it said I was missing the cairo dependency. I installed this, however, when I again tried to install GTK I got an error message like this:

*** 'pkg-config --modversion glib-2.0' returned 2.28.7, but GLIB (2.26.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files

It appears that even though I installed the latest version of GLib, traces of some older version (which was apparently not installed before) remain on my machine and are confusing the GTK installer. I have no idea how this 2.26.1 installation got there or how to remove it. I certainly never deliberately installed it. I have tried redownloading the GLIB archive, uninstalling and reinstalling it, and searching my drive for any files that appear related to GLib and deleting them (probably breaking stuff in the process). Nothing helps. Does anyone know how I can remove this phantom GLib 2.26.1 installation? Where else could it be hiding?

Also, I am running Ubuntu Maverick. I probably should have mentioned that earlier... I checked the package manager and couldn't find anything GLib-related installed there either.

share|improve this question
add comment

migrated from stackoverflow.com Jul 17 '11 at 11:50

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 2 down vote accepted

First of all, if you are running Ubuntu Maverick you had already glib installed before you started. Second: Why don't you install Audacity from the repositories of Ubuntu and skip the compiling part. Look at this: 1, 2

About replacing glib 2.26, I recommend you don't do such a thing, since Gtk+ version have hard version dependecy over Glib, and if you remove Glib 2.26 completely, maybe some Gtk application don't run at all, or maybe any Gtk application could run again. About cairo is almost the same, cairo is already on your system.

The most probable issue here is that you had installed both version of Glib and Cairo, just to different locations, the one the system uses should be on /usr/lib and the one you have installed should be on /usr/local/lib unless you had changed the installation path. If by the end you want to have both version at the same time I recommend you to manipulate LD_LIBRARY_PATH through a script so you don't affect you're main system with the newer versions of the libraries.

share|improve this answer
    
You are correct. It looks like I needed the _dev libraries, which I acquired through the package manager fairly easily. (After reinstalling Ubuntu...) –  dpitch40 Jul 25 '11 at 17:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.