Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Basically it stops recognizing all non alpha keys. Restarting eclipse does not fix the issue. Rebooting my computer does.

I'm using OS X 10.6.4 fully updated. :)

Anyone else experience this?

share|improve this question

migrated from Jul 17 '11 at 13:20

This question came from our site for system and network administrators.

I have this issue too, none of the "fixes" have ever worked for me. – NorthIsUp May 27 '11 at 19:05

Instead of killing the dock, you need to kill the Finder. To do this, you have to do "Apple + Alt + Escape" which shows you the force quit dialog, select the "Finder" and click "Relaunch". Your keys should be start working again.

I suspect it's something to do with an application crashing and then screwing up Java processes (this happened immediately after Firefox crashed).

All the best

share|improve this answer
I've tried this dozens of time, with no success. Only a reboot solves the problem. – bobber205 May 27 '11 at 16:52
works for me, thanks – cerberos Dec 29 '11 at 7:07

I have the same issue with disabled keys in Eclipse two times a month.

Solution: Quit Apple Mail.

share|improve this answer
+1 It actually worked!!! WTF? – Shanimal Aug 14 '12 at 20:12
This happens anytime I force wuit Firefox. When I close any program on the dock I regain access to the keys. – Shanimal Aug 14 '12 at 20:38

Killing the Dock process fixes this annoying issue.

share|improve this answer
This just happened to me again, with Eclipse refusing to recognize my keyboard. I tried – bobber205 Dec 30 '10 at 20:09
I tried killall -KILL Dock to no avail. :( The dock did indeed restart, but I am still having the issue. – bobber205 Dec 30 '10 at 20:10

For me the problem was my mouse.

It's 3rd key was engaged. It's an Evoluent Vertical Grip mouse and I never used the 3rd mouse button so I didn't realize that it was permanently pressed. Getting it unstuck fixed the problem.

share|improve this answer

I had the same problem, and the solution was pointed out in Jonah Dempcy's answer.

Although I don't have a mouse — I have a MacBook Pro with OS X Lion 10.7.2 and Aptana 3 — somehow middle click was activated (i.e. the third mouse button.

As soon as I used my custom shortcut for middle click, the problem disappeared. So, just click the third mouse button / wheel / shortcut a few times.

share|improve this answer

I have the same issue. I'm using a 17" Macbook Pro with OSX 10.7.4 and Aptana Studio 3.1.3. The solution that works for me is to put the laptop to sleep and then wake it up. Works every time. I also have an issue where I click on something on the desktop or dock and it gets stuck to the cursor as if I had click and drag enabled. The same solution of putting the computer to sleep and then waking fixes this as well. I'm assuming the two are somehow related and it is an OSX bug.

share|improve this answer

Happened to me on ZendStudio 7.2. I am using Macbook Pro with OSX 10.8.4. Putting notebook to sleep solved my problem.

share|improve this answer

You must log in to answer this question.

protected by Community Oct 1 '15 at 8:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .