Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I edit long text files in Notepad++ (4MB) and turn the word wrap on, it causes about a second delay between typing a letter and seeing it appear, rendering the editor in this mode practically unusable.

Other editors (PSPad, JEdit, Editpad Lite) don't have this problem.

What can I do in Notepad++ to allow it to not pause after each key stroke while I am editing 4MB text files with word wrap mode turned on?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Try your file in Notepad2 and SciTE as well. If they just as slow, you can assume that it is a weakness of the underlying Scintilla library.

share|improve this answer

You can try disabling any plugins and see if it helps. Unfortunately though, I think the ultimate answer if "Nothing" or "Switch Editors".

share|improve this answer

Try to disable "smoothing edges of screen fonts". If you use Windows XP you can disable it in this way:

  1. Right-click your Desktop.
  2. Click "Properties".
  3. Click the "Appearance" tab.
  4. Click the "Effects" button.
  5. If the "Use the following method to smooth edges of screen fonts" checkbox is checked you need to unchek it.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.