Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently managed to revive an antique Pentium 4 PC with the following specs:

  • Pentium 4 Northwood 2.0 GHz
  • ASUS P4SE mainboard (SiS 645 chipset)
  • nVidia GeForce4 Ti-4200
  • 1 GB DDR-400 RAM (Transcend)
  • Creative Labs SoundBlaster Live! DE 5.1 SE
  • TP-Link TL-WN951N PCI Wireless NIC (Atheros AR5008 Controller)
  • Windows XP Pro SP3

It works great for what it's intended (allowing guests to browse the Internet, edit and send documents, etc.). But, it would BSOD if I try to hibernate it, right after the screen that reads "Preparing to hibernate..." After disabling each and every single hardware in Device Manager, I can tell that the culprit is the wireless NIC because the computer can hibernate and wake up smoothly if said device is disabled. Installing latest available driver doesn't seem to have improved anything.

What can I do to fix this problem? Or, at least as a temporary workaround, does anyone know of a script that enables and disables a device so that users don't have to do it manually?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I've found a fix.

Turned out that the drivers provided by TP-Link weren't WHQL-certified. So I browsed around for WHQL-certified Atheros drivers and found quite a few of them here. I installed all of them, one at a time, and found version 7.7.0.523 to be a perfect match for my system. Now my antique PC sleeps and hibernates without a hitch, and signal reception seems to have improved a bit.

Lesson learned: In case of power-management-related problems, insist on WHQL-certified drivers.

share|improve this answer

If this was linux, I would have a solution for you... but writing a windows script to disable a hardware device on a kernel event specifically for hibernate doesn't sound like an easy or straight forward possibility.

With that said, is hibernate really that important? Sleep works decent enough for most purposes... but if you are bent on getting the thing to hibernate, I would suggest investing in a cheep $15 Wifi USB adapter and calling it a day.

share|improve this answer
    
Sorry I don't have a better solution for you, but as I said, it's not as easy as you may think. –  CenterOrbit Jul 17 '11 at 17:01
    
Sleep/suspend never works on this particular PC. And hibernate is much safer after all. Investing $15 is a good idea, provided there's a guarantee I won't be getting yet another problem. –  Larssend Jul 17 '11 at 19:15
    
Forgot to mention that I also got BSOD when trying to sleep/suspend the computer with wireless NIC enabled. Thanks for answering. –  Larssend Jul 17 '11 at 19:23
    
Yup, replace the card. You've already spent more than $15 of your time overthinking the problem. Good luck! –  user3463 Jul 18 '11 at 3:04
1  
@Larssend a) wherever you bought the card from should allow you to return it, places such as newegg etc... b) of course the community of superuser will continue to try and fully fix your problems ;) –  CenterOrbit Jul 18 '11 at 13:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.