Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm new to Fedora 15 and Linux. I've stumbled upon a problem while installing Oracle XE; I can't set environment variables or do anything else - any change I make won't stick.

I'm using the terminal:

$ su --login
Password: *******

As an example: if I run history -c then log out, after logging in again the bash history is still there(same happens with environment variables,they are not there, none of them).

My user has this cat /etc/passwd:

mark:x:500:500:mark:/home/mark:/bin/bash

What should I change or what am I missing?

EDIT: I don't know if it's important but it's a VMware virtual machine(on a Windows XP system)

share|improve this question

1 Answer 1

up vote 2 down vote accepted

What you probably need to do is set all the variables associated with Oracle XE in your .bash_profile or .bashrc script and ensure they are exported.

Environment variables only exist for the lifetime of the shell process where you set them. If you want them the next time you login, you need to set them again. You can automate this by setting them in the shell startup script. For bash, you can put them in either ~/.bash_profile or ~/.bashrc. .bash_profile is executed when you login, and .bashrc is executed each time you open a new bash shell.

If you want an environment variable to be available to processes launched by a shell, you must export the variable. For example, export foo=1 sets the value of foo to 1 and exports it to all child processes of the shell.

share|improve this answer
    
thanks, but the problem goes further. For example I can't set Chrome as my main browser. so I think maybe is related to the account permissions. –  MHero Jul 18 '11 at 16:19
    
I also am unable to make Chrome my default browser on Fedora 15 in Gnome 3. Never had any trouble with previous versions of Fedora/Gnome. –  cantfork Jul 18 '11 at 23:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.