Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been bugged by this issue ever since I installed Linux(mint) on my eeepc.

Scenario:

  1. List item
  2. Wireless modem router is connected to internet and sharing internet properly.
  3. EEE PC starts up and connects to router automatically, has internet connectivity. All systems are up and running fine.
  4. Router requires reboot for whatever reason or power shorts out. EEE PC stays on because it's running off battery power.
  5. Router comes back online and shares internet again.
  6. Other Windows computers reconnect automatically.
  7. EEE PC still left in "disconnected" state.

I've tried looking around at the admin options but there doesn't seem to be much.

I've also taken a look on the forums and many point to the iwconfig command. Checking the retry options, they seem to be on default.

wlan0

IEEE 802.11bgn ESSID:"twigwireless"
Mode:Managed Frequency:2.422 GHz Access Point: 00:04:ED:46:63:CB
Bit Rate=150 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off Encryption key:off Power Management:off Link Quality=54/70 Signal level=-56 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I'm pretty new to all this, but as I'd like to run the EEEPC as a headless box, it's a bit of a pain to drag it out just to reconnect to the wireless every once in a while.

share|improve this question
    
I need this too. Did you ever figure it out? –  Wyatt8740 Feb 6 at 21:41
    
Unfortunately not, I ended up leaving it plugged into ethernet. Upgraded to a newer version of Linuxmint, seems to be alright now. –  twig Feb 6 at 21:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.