Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Windows 7.

I have a Windows Explorer icon pinned to my taskbar.

When no Explorer window is open, clicking it takes me to “Libraries”, a folder that I never use. Is there a way to set a default folder to show here?

I already followed the steps in the vaguely-related question “Is there a way to set up a default folder for Windows Explorer?”, but it had no effect (indeed a comment there suggested it no longer works in Windows 7).

share|improve this question

8 Answers 8

up vote 14 down vote accepted

With all Windows Explorer windows closed, hold down Shift and right-click the Windows Explorer icon that is pinned to the Taskbar. Select Properties from the menu.

On the Shortcut tab, the Target: field is probably:

%windir%\explorer.exe

Add a space and the path to the folder you want to be your default. I changed my target to

%windir%\explorer.exe "C:\Users\william\"

Quotation marks around the folder path are only necessary if the path contains a space.

share|improve this answer
    
as @asok-smith pointed out in another answer... this way of modifying the shortcut leaves explorer processes in the background that accumulate... each of which takes over 10 MB of space... is there some way of working around that? –  user1055604 Dec 27 '12 at 19:04

From this article (Trick to Open Computer or Documents as Default Instead of Libraries Folder with Windows Explorer on Windows 7):

For user who doesn’t actually use Libraries, or prefer Windows Explorer to open up My Documents, Documents, or even Computer (the highest level view that shows all drives available on the computer), this trick will set Windows Explorer to open and show the prefer folder by default.

  1. In Windows 7 Start Menu, right click on the Windows Explorer shortcut (typically store inside All Programs -> Accessories) and then select Properties.

    On Windows 7 Taskbar, hold down Shift key, and then right click on the Windows Explorer icon, and then select Properties. If you already have one or more Windows Explorer windows open, right click on the Windows Explorer icon, and then right click on the Windows Explorer link again to click on Properties, as illustrated below.

    enter image description here

  2. In the Target text box under Shortcut tab, change the value to one of the following to open either Documents or Computer by default.

    To Make Documents as Default Folder to Open by Windows Explorer upon Launching

    %SystemRoot%\explorer.exe /n,::{450D8FBA-AD25-11D0-98A8-0800361B1103}

    To Make Computer as Default Folder to Open by Windows Explorer upon Launching

    %SystemRoot%\explorer.exe /e,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

    enter image description here

  3. Click OK when done. Now, Windows 7 Explorer will open Documents or Computer directly, skipping and bypassing Libraries, depends on what you set or configure on initial run.

share|improve this answer

All of these solutions result in an extra instance of the explorer.exe process each time the modified shortcut is used, and they accumulate until you logoff.

A simpler and better solution is simply to replace all of the "Windows Explorer.lnk" shortcuts throughout the system with an ordinary folder shortcut named "Windows Explorer.lnk" that points to whatever folder you've chosen.

Here's a little procedure that does this for Windows 7 and 8, where the replacement shortcut points to the %USERPROFILE% folder. The standard admonition should you try this is to first make a restore point as a precaution.

http://reliancepc.com/menu/tips/Downloads/ReplaceDefaultExplorerShortcuts.zip

Once unzipped, you can use 7zip to look inside the resulting .exe (which is a 7z SFX) and see what it does and that nothing nefarious is inside.

share|improve this answer

Simply make it a shortcut to the folder you want to use as default.

share|improve this answer

As far as I know this function isn't directly supported by Windows.

The fact is, that the taskbar allows you to pin programs, and not directories. So, the only way to get this to work, would be to change the command-line parameters for explorer.exe when it opens.

Right-click on the "Windows Explorer" option inside the Windows Explorer taskbar icon and click on properties.

Here you will find that the shortcut points to: %windir%/explorer.exe

All you need to do, is add the path that you want it to open after that ...

EXAMPLE:

%windir&explorer.exe "C:\Users\usernameHere\Documents\"

Just remember that this is an unclean way of doing it... And remember to keep the quotes around the path to make sure that any spaces in the path don't confuse the command line.

share|improve this answer

Do the steps in this thread require admin privs? On our corporate W7 Pro machines users do not have admin so right-clicking Explorer in the task bar shows no menu. (Security wise, you should run with a non-privileged user account and when requested in a UAC (User Auth Control) enter the admin password.)

Instead, as a non-admin user, I went to C:\Windows\explorer.exe and made a shortcut/alias on the desktop. With that shortcut I went to its properties menu (I forgot if I right-clicked or shift-right-clicked the shortcut) and pasted my desired directory to open when Explorer is opened (as directed elsewhere in this thread).

Then right-clicking will enable you to Pin to Taskbar and it appears to have replaced the Explorer already in the taskbar (which as a non-admin user couldn't be removed) with the one that points to the desired default directory.

This affects only the link in the taskbar. Widoze-E still opens to another directory (in my case Computer).

share|improve this answer

Combed through everyone's solutions here, and followed the link provided by Mehper to find the solution without creating extra instances of Windows Explorer.

  1. Pin Windows Explorer to the taskbar(library) [if it's not already pinned].

  2. Create a “My Computer” shortcut on to the desktop (drag Computer from start menu to desktop).

  3. Change the name of the “Computer” shortcut to “Windows Explorer”.

  4. (If desired) Change the icon by right clicking > properties > shortcut tab > change icon> select the normal Windows Explorer icon.

  5. Navigate to C:Users\%User%\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch\User Pinned\TaskBar

  6. Copy the new “Windows Explorer” shortcut that you just created on the desktop into the folder.

share|improve this answer

Per: "All of these solutions result in an extra instance of the explorer.exe process each time the modified shortcut is used, and they accumulate until you logoff."

To get Explorer to open in "Computer" I replaced the %SystemRoot% in -

%SystemRoot%\explorer.exe /e,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

with C:\Windows producing -

C:\Windows\explorer.exe /e,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

and tested it with the Task Manager {ctrl + alt + del select "Start Task Manager"}

Every time I launch this explorer configuration I get an instance under the "Applications" tab that disappears whether I cancel the Explorer instance itself or in the Task Manager itself. It seems that launching Explorer directly as a stand alone program from the C:Windows directory instead of %SystemRoot% removes that instance accumulation problem.

I made a similar change with the "Documents" solution, changed their names in their Properties TAB to "Explorer - Computer" and "Explorer - Documents" respectively. By using copies and leaving the original "Libraries" shortcut untouched I can now go directly to each instance with no conflict and n-number of clicks in the Explorer window to move from one to another.

share|improve this answer
    
%SystemRoot% is C:\Windows. (Unless you install Windows somewhere else, of course.) The two commands are equivalent. –  Timwi Feb 18 '13 at 13:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.